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Module 1 - Microsoft Dynamics NAV Development Environment 
 

1. Non-default property values 
 

Microsoft Dynamics NAV objects properties that have non default value of the property appear as bold in the Properties window. 
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Module 2 – Tables 
 

1. Database Schema Synchronization 
Source: Synchronizing Table Schemas - Microsoft Development network - https://msdn.microsoft.com/en-us/library/dn762357(v=nav.80).aspx and Sync-
NAVTenant - Microsoft Development network - https://msdn.microsoft.com/en-us/library/dn466418(v=nav.90).aspx  

 

When you design a table in Microsoft Dynamics NAV, you define the metadata for the table, such as the name and object ID, and the fields and their data types. This table 
definition describes the table that must be created in the SQL Server database to store business data. You create and modify the table definition by using the Microsoft 
Dynamics NAV Development Environment. When you make changes to the table definition in the development environment, or when you upgrade a Microsoft Dynamics 
NAV database to a newer version, you must synchronize the business database table schema with the new or changed table definition so that the two are the same. Table 
schema synchronization is performed by the Microsoft Dynamics NAV Server instance that connects to the business database. 
 
Depending on the changes to a table definition, you might have to consider how to handle the existing data in the business data table when synchronizing the schema. 
For example, you must decide whether to keep or delete the data. Some table definition changes, such as adding and renaming a field, adding a new table, or modifying 
C/AL code to a table, do not affect data in the database table and are considered to be non-destructive changes. With non-destructive changes, you can synchronize the 
schema without any special data handling considerations. However, if you make destructive changes to the table definition, such as removing a field, then you will be 
warned by the development environment when you try to save the changes, and you must specify how to handle the data when synchronizing the schema. 
 
Synchronizing Table Schemas with SQL Server 
 
You can synchronize table schemas from the Microsoft Dynamics NAV Development Environment or by using the Sync-NAVTenant cmdlet in the Microsoft Dynamics NAV 
2015 Administration Shell. 
 
Synchronizing the Table Schema for Specific Tables From the Development Environment 
 
In the development environment, you can synchronize the table schema for a specific table or for all tables. You have the option to synchronize a table schema when you 
perform one of the following operations on a table from the development environment: 

• Save 
• Save As 
• Compile (This also pertains when you select multiple tables for compiling from Object Designer). 

https://msdn.microsoft.com/en-us/library/dn762357(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn466418(v=nav.90).aspx
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• Delete (This also pertains when you select multiple tables for deleting from Object Designer). 
 

 
 
Schema Synchronization Options  
 
When you perform one of the operations on a table, you can choose from the following schema synchronization options: 
 

Option  Description  

Now - with 

validation  

Before applying changes to the business data table, Microsoft Dynamics NAV Server validates the changes to the table definitions to check whether they 

are destructive changes. This includes changes that will delete data in the fields of the business data table which are affected by the changes. 

• If there are no destructive changes to the table, then the schema changes are applied to the business data table immediately. 

• If there are destructive changes, Microsoft Dynamics NAV Server checks that there are table synchronization instructions in an upgrade codeunit. 
If there are instructions, then the schema changes are applied to the business database table according to the instructions. If there are no 
instructions, then an error message appears. The table definition changes are not saved and the schema changes are not applied. 
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Later  

Table definition changes are saved and compiled in the application but the changes are not validated or applied to the business data table. You 

synchronize the table schema later by doing one of the following: 

• Save or compile the table from Object Designer in development environment and choose either the Now - with validation or Force 
synchronization option.  

• Use the Sync. Schema for All Tables option on the Tools menu. 

• Run the Sync-NAVTenant cmdlet from the Microsoft Dynamics NAV 2015 Administration Shell. 

Force  

Table definition changes are applied to the business data table schema without validation. For destructive changes, data in columns of the business data 

table that are affected by changes will be deleted.  

This option ignores any table synchronization instructions for the table in upgrade codeunits. 

 
Synchronizing All Table Schemas From the Development Environment 
 
From the development environment, you can synchronize table schema changes for all tables in the database. This is useful when you upgrade from an earlier version of 
Microsoft Dynamics NAV or when you made changes to a table or multiple tables previously and chose to synchronize later. 
 
To synchronize schema changes for all tables, on the Tools menu, under Sync. Schema For All Tables, you can choose one of the following options: 
 

Option  Description  

Check Only  

Microsoft Dynamics NAV Server validates the table definition changes but does not apply the schema changes to the business database. 

• If there are no destructive changes to any of the tables, no errors occur. 

• If there are destructive changes, Microsoft Dynamics NAV Server checks that there are table synchronization instructions in an upgrade codeunit. If 
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there are instructions, then no errors occur. If there are no instructions, an error occurs. 

For more information about how Microsoft Dynamics NAV Server validates changes, see the How Microsoft Dynamics NAV Server Validates Table Schema 

Changes section. 

With 

Validation  

Before applying changes to the business data table, Microsoft Dynamics NAV Server validates the table definition changes to check for destructive changes 

to the table. 

• If there are no destructive changes to the table, then the schema changes are applied to the business data table immediately. 

• If there are destructive changes, Microsoft Dynamics NAV Server checks that there are table synchronization instructions in an upgrade codeunit. If 
there are instructions, then the schema changes are applied to the business database table according to the instructions. If there are no 
instructions, then an error message appears. Table definition changes are not saved and the schema changes are not applied. 

For more information, see How Microsoft Dynamics NAV Server Validates Table Schema Changes. 

Force  

Table definition changes are applied to the business data table schema without validation. For destructive changes, data in columns of the business data 

table that are affected by changes will be deleted. 

This option ignores any table synchronization instructions for the table in upgrade codeunits. You should use this option only when you are sure that there 

is no risk of unwanted data loss. 

 

https://msdn.microsoft.com/en-us/library/dn762357(v=nav.80).aspx#ServerValidation
https://msdn.microsoft.com/en-us/library/dn762357(v=nav.80).aspx#ServerValidation
https://msdn.microsoft.com/en-us/library/dn762357(v=nav.80).aspx#ServerValidation
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Sync-NAVTenant cmdlet 
 
Use the Sync-NAVTenant cmdlet to synchronize the database schema in a tenant database with the schema in the application database. 
 
Parameters 
-Force 
Forces the command to run without asking for user confirmation. 
 
-Mode<Int> 
Specifies how the database schema for the tenant database is synchronized with the database schema that the mounted application database defines. The default value is 
Sync, ForceSync = 0, Sync = 2 and CheckOnly = 3. 
 
-ServerInstance<String> 
Specifies the Microsoft Dynamics NAV Server instance that the application database and the tenant database are mounted against, such as DynamicsNAV90. 
 
-Tenant<TenantId> 
Specifies the ID of the tenant that you want to synchronize with the application, such as Tenant1. 
 
Example:  
PS C:\> Sync-NAVTenant –ServerInstance DynamicsNAV90 -Tenant 'Tenant1' 
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Module 3 – Pages 
 

1. Mandatory Fields 
Source: Simplified UX - White Paper - Brian Nielsen (Principal Program Manager), Nikola Kukrika (Software Engineer), Jacob Winther (Senior UX Designer), 
July 2014, Microsoft 

Less experienced users often do not know which fields to fill in as a minimum, for 
example on the customer card, for the customer to be used in processes, such as 
invoice posting. All the help they get is an error message when they try to 
complete the process. 
 
To help users with this issue, the ShowMandatory property has been introduced. 
In this context, “mandatory” means that a field is marked with red asterisk to 
indicate to users that they are expected to fill the field. The user can still leave 
page without getting error messages if the field is not otherwise validated by 
business logic. 
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To set the field as mandatory developer can change value of property 
ShowMandatory. 
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2. UI Elements Removal 
Source: Microsoft Dynamics NAV 2015 - Simplified UX - Brian Nielsen (Principal Program Manager), March 2014, Microsoft 

 
NAV 2015  remove UI Elements not in the 
user’s license or permissions set the UI 
can be made very simple, only showing 
the things the user have access to. 
 
Example with a sales order processor with 
a very restricted permission set before 
and after the system removes UI elements 
not in the user’s permissions. 
 
Before UI Elements were removed. 
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After UI Elements were removed. 
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3. UI Elements Removal Setup 
Source: How to: Specify When UI Elements Are Removed, Microsoft Dynamics NAV 2015, Microsoft Developer Network - https://msdn.microsoft.com/en-
us/library/dn271718(v=nav.80).aspx and How to: Remove UI Elements Using the AccessByPermission Property, Microsoft Dynamics NAV 2015, Microsoft 
Developer Network - https://msdn.microsoft.com/en-us/library/dn789564(v=nav.80).aspx 

 

How to Specify When UI Elements Are Removed 
 
Depending on the setting in the UI Elements Removal field in the 
Microsoft Dynamics NAV Server Administration tool, only user 
interface (UI) elements on objects in the license or on objects that 
the user has permissions to will appear in the user interface. 
 
All types of UI elements will be removed if they relate to objects that 
are not included in the license or the user does not have the 
required permission to the objects: 

• Fields 
• Actions 
• Page parts 

 
UI elements that are directly related to an object through the 
TableRelation or the CalcFormula property can be removed 
automatically according to the license file and/or user permissions. 
 
To specify when UI elements are removed user can change settings 
using Microsoft Dynamics NAV Server Administration tool. In the UI 
Elements Removal field user can choose one of following options: 
 

• None - All UI elements are displayed, even if the license file 
does not include the related object and the user does not 
have permissions to the related object. 

• LicenseFile - A UI element is removed if the related object is 

 

https://msdn.microsoft.com/en-us/library/dn271718(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn271718(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789564(v=nav.80).aspx
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not included in the license file. 
• LicenseFileAndUserPermissions -   
• A UI element is removed if the related object is not included 

in the license file and the user does not have permissions to 
the object as defined in the AccessByPermission property for 
the related UI element. By default, this option is selected. 

  
How to: Remove UI Elements Using the AccessByPermission 
Property 
 
For UI elements that are not directly related to an object, you can 
use the AccessByPermission property to remove the element 
according to the user’s permission to a related object.  
 
The AccessByPermission property sets a value for a table field or UI 
element that determines the permission mask for an object that a 
user must have to see and access the related page fields or UI 
element in the client. The UI element will be removed at runtime if 
the user does not have permissions to a certain object as specified in 
the Access By Permission window. 
 
To remove UI elements by using the AccessByPermission property 
developer can do following: 
 

• In the Microsoft Dynamics NAV Development Environment, 
view the properties of a table field for which you want to 
remove its page control(s) or view the properties of a field, 
action, or part on a page object. 

• For the AccessByPermission property, choose the AssistEdit 
button. 

• In the Access By Permission window, fill the fields as 
described next: 

o Object Type - Specify the type of object to which 
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permission is required for the UI element to be 
visible. Object ID - Specify the object to which 
permission is required for the UI element to be 
visible. 

o Read - Specify if Read permission is required for the 
UI element to be visible. 

o Insert - Specify if Insert permission is required for 
the UI element to be visible. 

o Modify - Specify if Modify permission is required for 
the UI element to be visible. 

o Delete - Specify if Delete permission is required for 
the UI element to be visible. 

o Execute - Specify if Execute permission is required 
for the UI element to be visible. 

o When multiple permissions are selected, then one 
or another applies. For example, if you choose Insert 
and Modify, then the user must have either the 
Insert or the Modify permission to the object for the 
UI element to be visible. 

• Save and compile the changes. The UI element in question is 
now invisible to users who do not have the specified 
permissions to the object. 
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4. Defining Action Scope for NAV Page 
Source: Defining Action Scope for Microsoft Dynamics NAV Pages, Microsoft Dynamics NAV 2015, Microsoft Developer Network - 
https://msdn.microsoft.com/en-us/library/dn789514(v=nav.80).aspx 

 

 
Defining Action Scope for Microsoft Dynamics NAV Pages 
 
When developing pages for Microsoft Dynamics NAV Tablet and Web client that 
include a repeater control, it is useful to be able to define whether the actions 
available on a page apply to the whole page or are related to the repeater control 
on the page. The purpose of the Scope property is to enable application 
developers to add row-specific actions to the shortcut menu which is available to 
the user on each line. This gives users a more direct way to invoke actions that 
relate to the selected row/line. 
 
This is the case when you have, for example, Line Comments which are related to 
a line, but appear in the ribbon. You can specify the scope of action by setting the 
property on the page action to be either Page or Repeater. 
 

 
 
 

https://msdn.microsoft.com/en-us/library/dn789514(v=nav.80).aspx
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Tablet Client 
 
Scope property = Repeater – action is displayed only in repeater scope. 
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Web Client 
 
Scope property = Repeater – action is displayed in action ribbon and in repeater 
scope as well. 
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5. Update Parent Page from a Subpage 
Source: UpdatePropagation Property, Microsoft Dynamics NAV 2015, Microsoft Developer Network - https://msdn.microsoft.com/en-
us/library/dn789582(v=nav.80).aspx 

 

Update Parent Page from a Subpage 
 
Sets a value that specifies what happens when a main 
page with a subpage is updated. The UpdatePropagation 
property is available on Part controls and has two options; 
Subpage and Both. If UpdatePropagation is set to 
Subpage, an update action will update the subpage only. If 
UpdatePropagation is set to Both, an update action will 
update both the main page and the subpage. This is useful 
if a value on the subpage changes, and you want a main 
page total to be refreshed automatically. 
 

 
 
Example: 
Create new field on Sales Order page – No. of Lines which 
will automatically calculate number of lines created for 
the Sales Order. 
 

1. Create new non-editable field No. of Lines – int – 
Flowfield in table Sales Header. Flowfield 
calculates number of existing records in table 
Sales Line for Document Type and Document No. 
same as for Sales Header. 

 

https://msdn.microsoft.com/en-us/library/dn789582(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789582(v=nav.80).aspx
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2. Add new field to Sales Order page. 
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3. Change Update Propagation Property to Both for 
subpage with lines. 

 

 
4. Add CurrPage.UPDATE(); call on appropriate 

subpage trigger, for example OnNewRecord. 
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6. Lab - Update Parent Page from a Subpage 
Source: Demo Script - Refreshing Parent Page with UpdatePropagation, Stuart Glasson (Program Manager), August 2014, Microsoft 

 

The scenario in this lab is to build a header/subpage pattern page and display a current total in the header. At the end, you will create a page that looks and 
behaves like the page in the following illustration where the sum of the values is totalled in the General FastTab without a user needing to refresh the page. 
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What to do What to say Screenshots 

1. Open the Microsoft Dynamics NAV 
2015 Development Environment. 

2. On the Tools menu, choose Object 
Designer.  

So, let’s get started by 
opening the 
Development 
Environment and 
Object Designer.  
 

  
3. Choose Table and then choose New. 

a. Specify two fields: 
• Int as Integer 
• Value as Decimal 

b. Save the table as follows: 
ID: 50006 
Name: SubTable 

c. Close Table Designer. 
 

Build the table that 
will be the data 
source for the 
subpage. 
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4. Choose Table and then choose New. 
a. Specify two fields: 

• Key as Integer 
• Total as Decimal 

b. Select the Total field and open 
the Properties window 
(Shift+F4). 

c. Set the FieldClass property to 
FlowField. 

d. In the CalcFormula property, 
choose the AssistEdit button to 
open the CalcFormula wizard. 

e. Set the following formula: 
Method: Sum 
Table: SubTable 
Field: Value. 

f. Choose the OK button and 
close the Calculation Formula 
wizard and then close the 
Properties window. 

g. Save the table as follows: 
ID: 50005 
Name: MainTable 

h. Close Table Designer. 
 

Next, build the table 
that will be the data 
source for the main 
page. 
 
Note that the total for 
the Total field is a 
FlowField calculated 
as the sum of values 
from table 50006.  
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5. Choose Page and then choose New. 
a. Specify the following: 

Table: SubTable 
Create a Page: ListPart 

b. Add both fields. 
c. Close, save, and compile the 

page:  
ID: 50006 
Name: SubPage 

 
 

Now that you have 
your data sources, it’s 
time to build the 
pages.  
 
First, build the 
subpage that will 
show the line 
information. For this, 
use the Page Designer 
wizard and pick a 
ListPart page type. 
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6. Choose Page and then choose New. 
a. Specify the following: 

Table: MainTable 
Create a Page: Document 

b. Choose the OK button. 
c. Choose Next to create a 

General FastTab. 
d. Add the Total field to the Field 

Order list box. 
e. Choose Finish. 
f. Select the first empty line and 

add a new entry: 
Type: Part  
Subtype: Page. 

g. Choose the left arrow button to 
indent the subpage entry one 
step back. 

h. Open the Properties window 
for the Part:Page entry and set 
the PagePartID property to 
SubPage.  

7. Choose Preview. 
8. Close, save, and compile the page: 

ID: 50005 
Name: MainPage. 

 

Next, build the main 
page, which will show 
the header 
information. Again, 
use the Page Designer 
wizard and this time 
pick the Document 
page type. 
 
As you make the 
page, you only want 
to display the total 
value in the header. 
 
After adding the Total 
field, close the Page 
Designer wizard and 
add the subpage to 
the main page. 
 
In Page Designer, add 
the subpage to the 
page. Make sure to 
choose the left arrow 
to indent the subpage 
entry one step back. If 
you do not do this, 
the subpage part will 
display next to the 
Total field and you 
want it to be 
underneath. 
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Choose the Preview 
button to see if you 
are on track. 
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9. From Object Designer, run Table 
MainTable.  

10. The MainTable table opens. 
Enter 1 in the table. 

11. Choose the OK button to close the 
page. 

12. Switch back to the development 
environment. 
 

To test this, add a 
demo data record to 
the main table. From 
Object Designer, run 
Table Main Table and 
add the number 1 to 
the table. 
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13. From Object Designer, run Page 
MainPage. 
The Microsoft Dynamics NAV 
Windows Client opens and displays 
the page. 

14. On the Manage tab, choose Edit.  
Add some test values. 
 

Now, test if the 
header/subpage 
solution works. 
 
Run the Main Page. 
 
Add some values and 
notice that as you add 
them, the Total field 
does not update. If 
you refresh the page, 
then it does, but it 
does not do it 
automatically. 
 
Let’s fix that with the 
new 
UpdatePropagation 
functionality.  
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15. Return to the development 
environment. 

16. Open the MainPage in the Page 
designer. Select the Part:Page line 
and open the Properties window 
(Shift + F4). 

17. Set the UpdatePropagation 
property to Both. 

18. Close and save the MainPage page. 
 

Change the setting of 
the 
UpdatePropagation 
property on the Page 
Part from SubPart to 
Both. This means any 
refresh or page 
update from the 
subpage will refresh 
the parent page too. 
 
 

 

19. Open the SubPage page in Page 
Designer.  

20. Select the Value line and open the 
C/AL code editor (F9). 

21. Find the Value OnValidate trigger 
and add the following line of code 
CurrPage.Update(); 
 

22. Close the code editor and save the 
page. 
 

Next, you want to 
make the subpage 
refresh itself on 
changes. Add AL code 
for a page refresh to 
the OnValidate trigger 
of the field. 

 

23. Run the MainPage page again. 
24. Choose Edit, and add more values 

to the lines. 
. 

Now, run the 
MainPage page again. 
As you add values in 
the subpage, notice 
the automatic refresh 
of the total in the 
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header. 
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Module 4 - Introduction to C/AL Programming 
 

1. Variable Scope - Auto-generating of C/AL variable and parameter names for complex data types 
 

When defining global or local variable (C/AL Globals or C/AL 
Locals) or function parameter of complex data type Record, 
Codeunit, Page, Query, Report, TestPage, and XMLPort, NAV 
2015 Development Environment creates Name of that 
variable/parameter automatically using name of the 
associated NAV object. 
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Module 6 - C/AL Statements 
 

1. The Syntax of Comments - Multiple lines comments 
 

In order to comment multiple lines of code, select lines and then go to Edit 
menu and use Comment Selection or Shift+Ctrl+K. 
 
In order to uncomment multiple lines of code, select lines and then go to 
Edit menu and use Uncomment Selection or Shift+Ctrl+O. 
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Module 7 - C/AL Functions 
1. Functions and Parameters - C/AL functions are local by default 

 

New functions are local by default, property Local is set to 
Yes. Local function is not accessible outside the object in 
which is it defined. 
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Module 8 – Reports 
 

1. Word Document Reports 
Source: Demo Script – Word Document Reports and Custom Layout, Microsoft 

Benefits: 

• Users are familiar with Word 
• Flexible layout  
• WYSIWYG 

 

Limitations 

• Not suitable for complex layout or very large documents 
• Conditional formatting is not supported 
• Number formatting limited to built-in NAV numbers 

 

Lab 1 — Using Report Selector to run Report 1306 Instead of Report 206 
Lab story: Microsoft Dynamics NAV 2015 ships with the following a set of new and simplified sales document reports: 

• 1304 Mini Sales – Quote 
• 1305 Mini Sales – Confirmation 
• 1306 Mini Sales – Invoice  
• 1307 Mini Sales – Credit Memo 

 

Out of the box, the customary reports 204, 205, 206, and 207 are still enabled by default. To use the new reports, you set them up by using the report 
selection feature. In this lab, the required steps to use the new sales document reports are shown. 

 



Microsoft Dynamics NAV 2015 Developer 
 

38 
 

What to do What to say Screenshots 

1. Open the Report Selection – 
Sales page by doing one of the 
following: 
• In the Search box, enter Report 

Selection – Sales, and then 
choose the related link. 

• In the navigation pane, choose 
Departments, Administration, IT 
Administration, and then 
Reports. 

 
 
 
 
 

For the remaining labs, 
instead of running the 
default report “206 
Sales – Invoice”, we 
want to run the newly 
designed Sales Invoice 
report, that is, report 
“1306 Mini Sales – 
Invoice.” 
 
To do this, we will use 
the Report Selection 
feature. 

 
  

2. In the Report Selection – Sales 
window, do the following: 
a. Set the Usage field to 

Invoice.  
b. In the Report ID field, 

replace 206 with 1306. 
c. Choose the OK button. 

Set up the report 
selection to run report 
1306 instead of report 
206 when printing 
invoices. 
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Lab 2 — Managing Report Layouts 
Lab story: Microsoft Dynamics NAV 2015 enables reports to have a single built-in RDLC and Word layout, shared among tenants, as well as any number of 
customized layouts per tenant. To browse and manage which layout is currently used for a given report, a new Report Layout Selection list page has been 
introduced.  

In this lab, we will use the Report Layout Selection page to switch between and run the RDLC and Word layouts that are shipped as part of the new Sales 
Invoice report 1306. 

 

What to do What to say Screenshots 

1. Open Report Layout Selection 
page by doing one of the 
following: 
• In the Search box, enter Report 

Layout Selection, and then 
choose the related link. 

• In the navigation pane, choose 
Departments, Administration, IT 
Administration, Reports, and 
then Report Layout Selection. 

• In the Small Business Role 
Center, on the Actions tab, 
choose Setup, Company 
Information, and then choose 
Report Layouts. 

2. Ensure that the Company 
Name field is set to the correct 
company because reports 
layouts are company-specific. 

The Report Layout 
Selection page lists all of 
the reports that are 
available for the 
company that is specified 
in the Company field at 
the top of the window. 
 
The Selected Layout field 
specifies the layout that 
is currently used for a 
given report.  
 
A report can be set up 
with more than one 
report layout, which you 
can then switch among 
as needed. 
 
Depending on the layouts 
that are available for a 
report, you can choose to   
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use a built-in RDLC 
layout, a built-in Word 
layout, or a custom 
layout. 
 
From the Report Layout 
Selection page, it is also 
possible to manage 
custom layouts for 
reports. 
 
 
 
 
 
 
  

3. In the list, locate the document 
report 1306 Sales – Invoice by 
doing one of the following: 
• Scroll down through the list. 
• Filter on the Report ID equal to 

1306. 
4. Select the row for report 1306. 
5. Choose the down arrow in the 

Selected Layout field to show 
the options (RDLC, Word, and 
Custom). 

First we will have a look 
at the new report 1306 
Sales - Invoice, which has 
a built-in RDLC and Word 
layout. Out of the box, it 
does not have any 
custom layouts – we will 
add these in later labs. 
 
As you can see, the RDLC 
(built-in) is typically the 
layout that selected by 
default. This can, 
however, be controlled 
by using the Default 
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Layout property on the 
specific report object in 
Microsoft Dynamics NAV 
Development 
Environment. 
Notice that the page also 
contains a Custom 
Layouts FactBox. This 
lists any available custom 
layouts for a selected 
report in the list. If there 
are no custom layouts for 
the report, then you will 
have to create one first. 
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6. In the row for report 1306, set 
the Selected Layout field to 
RDLC (built-in). 

7. On the Home tab, in the Report 
group, choose Run Report.  

8. In the resulting report request 
page, use default values, and 
then select the Print button and 
choose PDF. 

9. Open and inspect the resulting 
PDF file for report, which is 
based on the RDLC layout. 

We will now select and 
run the built-in RDLC 
layout for report 1306 
Sales – Invoice from the 
Report Layout Selection 
list page. 
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10. In the Report Layout Selection 
page, select the line for report 
1306, and then set the Selected 
Layout field to Word (built-in). 

11. On the Home tab, in the Report 
group, choose Run Report. 

12. In the resulting report request 
page, use default values, and 
the select the Print button and 
choose PDF. [Note: This might 
not work for all client setups 
because it relies on server-side 
PDF conversion. As an 
alternative, use the Preview 
option on the request page, 
which will result in a Word 
document.) 

13. Open and inspect the resulting 
PDF file for the report, which is 
based on the Word layout. 

Finally, we will change 
the layout to the built-in 
Word layout and then 
run the report. 
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Lab 3 — Customize Report 1306 Sales Invoice Word Layout: Simple Formatting 
Lab story: Microsoft Dynamics NAV 2015 enables end users to customize RDLC and Word based report layouts. By default, a report will have a built-in 
report layout, which can be either an RDLC report layout or Word report layout, or both. You cannot modify built-in layouts. However, you can create your 
own custom layouts that enable you to change the appearance of a report when it is viewed, printed or saved. You can create multiple custom report 
layouts for the same report, and then switch the layout that is used by a report as needed. 

To create a custom layout, you can either make a copy of an existing custom layout or add a new custom layout, which in most cases is based on a built-in 
layout. When you add a new custom layout, you can choose to add an RDLC report layout type, Word report layout type, or both. The new custom layout 
will automatically be based on the built-in layout for the report if one is available. If there is no built-in layout for the type, then a new blank layout is a 
created, which you will have to modify and design from scratch. 

This lab showcases how non-technical end users, such as Annie or Stan, can customize the sales invoice document report by adding a new custom Word 
layout based on the built-in Word layout, changing the formatting to the desired visual identity, and setting the new custom layout to the active layout for 
the sales invoice report. 
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What to do What to say Screenshots 

1. Open Report Layout Selection 
page by doing one of the 
following: 
• In the Search box, enter Report 

Layout Selection, and then 
choose the related link. 

• In the navigation pane, choose 
Departments, Administration, IT 
Administration, Reports, and 
then Report Layout Selection. 

• In the Small Business Role 
Center, on the Actions tab, 
choose Setup, Company 
Information, and then choose 
Report Layouts. 

2. Ensure that the Company 
Name field is set to the correct 
company because reports 
layouts are company specific. 

3. In the list, locate the document 
report 1306 Sales – Invoice by 
doing one of the following: 
• Scroll down through the list. 
• Filter on the Report ID equal to 

1306. 
 

The normal starting point 
for customizing a report 
is from the list of reports 
in the application, i.e., 
from the Report Layout 
Selection page. 
 
A contextual option, e.g., 
from the request page, is 
not yet supported. 
 
As we want to customize 
the 1306 Sales Invoice, 
the first step is to browse 
to this in the report list 
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4. Select the row for report 1306, 
and then on the Home tab, in 
the Process group, choose 
Custom Layouts. 

The Custom Layouts page 
is used to create and 
manage custom layouts 
for a selected report.  
 
Out of the box, the list is 
empty, because there are 
no custom layouts. 
 
Notice that the Custom 
Report Layouts page can 
be opened by itself by 
searching for the page or 
using the Departments, 
or, as here, from the 
context of a given report. 
In the case of the latter, 
the page is filtered to the 
selected report ID when 
opened. If opened on its 
own, the page lists all 
custom layouts across all 
reports, which is useful 
when managing layouts 
for multiple reports. 
 
The Custom Layouts 
page is also accessed 
from the Selected Layout 
field on Report Layout 
Selection page. In this 
case, the Custom Layouts 
page works as a lookup. 
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In this mode, it is still 
possible to create and 
modify layouts. However, 
when you select a layout 
in Custom Layouts page, 
and then choose the OK 
button to close the page, 
the selected layout 
becomes the active 
layout for the report. 

5. On the Home tab, in the New 
group, choose New to insert a 
new custom layout. The Insert 
Built-in Layout for a Report 
window appears. The ID and 
Name fields are automatically 
filled in 

6. To add a custom Word report 
layout type, select the Insert 
Word Layout check box, and 
then choose the OK button, 

7. In the Custom Report Layouts 
page, in the Description field, 
rename the newly created 
custom layout to “My Word 
layout”. 

The built-in layouts 
themselves cannot be 
edited, therefore we are 
going to create a new 
Word report layout 
based on (or in other 
words, a copy of) the 
built-in Word layout, and 
then customize that 
layout further. 
 
The new custom layout 
appears in the Custom 
Report Layouts page.  
 
If a new layout is based 
on a built-in layout, then 
it has the words Copy of 
Built-in Layout in the 
Description field. If there 
was no built-in layout for 
the report, then the new 
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layout has the words 
New Layout in the 
Description field, which 
indicates that custom 
layout is blank. 
 
The Custom Report 
Layouts list includes a 
Type column that 
indicates whether the 
custom layout is RDLC or 
Word based. It also 
includes the Company 
Name column that allows 
you to specify whether 
the layout should be 
company specific. In this 
case, we have made the 
custom layout apply to 
all companies by leaving 
the field blank. 
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8. On the Home tab, in the 
Process group, choose Edit 
Layout. 

With the custom layout 
created, we will now edit 
it in Word. 
 
Note that the Edit 
function relies on client-
side automation, and 
therefore requires that 
the Microsoft Dynamics 
NAV 2015 Windows 
client and Word 2013 are 
installed. 
 
If you are using the 
Microsoft Dynamics NAV 
2015 Web client or a 
device, the custom 
layout can be edited by 
manually exporting the 
layout to a Word (.docx) 
file, editing it in Word, 
and then importing the 
layout file back into the 
appropriate report. 
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9. Look at the Word report layout 
content. 

A Word report layout is a 
Word document with 
content controls laid out 
in either free form or in 
table structures, which 
can even be repeating. 
 
The content controls 
themselves map to fields 
in the report dataset. 
 
In this lab, we will 
continue changing some 
of the formatting, and 
then in a later lab look at 
how to add content 
controls (fields). 
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10. Change the fonts as follows: 
a. Select all text (Ctrl+A). 
b. On the Home tab, in the 

Font group, change the 
font to Comic Sans.  

11. Change the font size and colour 
of document title and 
document no. as follows: 
a. In the header, select the 

DocumentTitle_Lbl control, 
and then increase font size 
a couple of steps and 
change the colour to Blue, 
Accent 1 (top row in 
normal colours). 

b. Repeat for the 
DocumentNo control. 

12. Add a style to the item lines 
item table as follows: 
a. Select the item lines table. 
b. On the Design tab under 

Table Tools, expand the 
Table Styles control. 

c. Select Grid Table 4, accent 
1 (blue, with solid header 
and alternating rows). 

13. Insert a glowing “Enjoy 
Microsoft Dynamics NAV2015!” 
greeting as follows: 
a. Add text to the end of the 

document. 
b. Select the text, and then on 

Home tab, in the Font 

In Word, we are going to 
make some format 
customizations and insert 
a greeting. 
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group, select the A in the 
Text Effects and 
Typography field. 

c. Choose second entry in 
second row (Gradient Fill – 
Blue, Accent 1, Reflection). 

d. Change the font size to 12. 

14. Save the changes and close the 
Word document. 

15. On the confirmation dialog that 
appeared when the layout was 
opened for editing, choose Yes 
to import the revised layout in 
the Microsoft Dynamics NAV 
client. 

With the changes in 
place, the Word layout is 
saved and imported back 
into Microsoft Dynamics 
NAV 2015. 

 

16. In the Custom Report Layouts 
page, select the new custom 
layout, and then on the Home 
tab, in the Report group select 
Run Report. 

17. In the request page, use 
default values, choose the 
Print button, and then choose 
PDF. 

18. Open and inspect the result 
file. Validate the font, colour 
and size changes, the table 
style, and the greeting. 

Before setting the new 
custom layout as the 
active layout for the sales 
invoice report, we are 
going to test it out by 
running it from within 
the Custom Report 
Layouts page. 
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19. Open Report Layout Selection 
page again. 

20. Locate and select the report 
1306 Sales Invoice, 

21. Change Selected Layout field 
to Custom 

Being satisfied with the 
new layout, we are now 
going to make this the 
default layout for the 
sales invoice report. 
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22. In Custom Report Layouts page 
that appears, select layout “My 
Word layout” that you just 
created, and then choose the 
OK button to close the lookup. 

23. Verify that the Selected Layout 
field is now set to Custom and 
the Custom Layout Description 
field is set to “My Word layout” 
for the report 1306. 

To do this, we will set the 
Selected Layout field in 
the Report Layout 
Selection page to the 
newly created custom 
layout.  
Note that if the Selected 
Layout field is already set 
to Custom, then the 
actual custom layout is 
changed by using the 
lookup in the Custom 
Layout Description field 
instead. 

24. Open Posted Sales Invoices by 
doing one of the following:  
• In the Search box, enter Posted 

Sales Invoices, and then choose 
the related link.  

• In the navigation pane, choose 
Posted Documents, and then 
Posted Sales Invoices. 

25. Select a sales invoice from the 
list, and then on the Home tab, 
in the Invoice group, choose 
Print. 

26. In the print dialog, use default 
values, select the Print button, 
and then choose PDF. 

27. Verify that the resulting PDF 
file is using the custom layout 
“My Word layout” that you 
created previously. 

Finally, we will run the 
sales invoice from a real 
application context, e.g., 
Posted Sales Invoices, to 
verify that the new 
custom layout is used. 
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Lab 4 — Customize 1306 Sales Invoice Word Layout: Adding Fields and Changing Structure 
Lab story: Microsoft Dynamics NAV 2015 enables end users to customize RDLC and Word based report layouts, both from a formatting point of view, as 
well as changing the structure and adding new fields from the report’s dataset.  

This lab showcases how power users, such as Sean, or technically experienced personas, such as Annie or Stan, can customize the Word based document 
reports, like the Sales Invoice report, to include desired fields and layout structure. The lab assumes that lab 3 has been completed, and that there is already 
a custom layout available for the document report 1306 Sales Invoice. If this is not the case, the lab can still be run but with the small variation that a new 
custom layout based on the built-in Word layout should be used, instead of copying an existing custom layout. 

 

What to do What to say Screenshots 

1. Open Custom Report Layouts page by 
doing one of the following:  
• In the Search box, enter Custom Report 

Layouts, and then choose the related link. 
• In the navigation pane, choose 

Departments, Administration, IT 
Administration, and then Reports. 

First, we want to make a copy of the 
previously created custom report 
and work on that. Once the layout is 
completed and tested, we will 
switch over to using the layout 
created in this lab. 
 
Rather than opening Custom Report 
Layouts from the context of a 
specific report in the Report Layout 
Selection list, we are now going to 
open it directly. Note that doing this 
will display all custom layouts 
unfiltered across all reports in the 
tenant. In this case though, we still 
only have a single entry from the 
previous lab. 
 
An alternative to opening the 
Custom Report Layout page on its 
own, is to open it for a specific 
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report from the Report Layout 
Selection page, and then remove 
the report ID filter which has been 
set. 

2. Select the “My Word layout” row, and on 
the Home tab, in the New group, choose 
Copy. 

3. In the Description field, rename the newly 
created layout to “My advanced Word 
layout”. 

 

We are going to add fields to the 
custom layout made in the previous 
lab. However, instead of modifying 
that layout directly, we are going to 
create a copy. This lets you work 
with and test the layout without 
risking impact to an actively used 
layout. 
 

  
4. Select the “My advanced Word layout” 

row, and then on the Home tab, in the 
Process group, choose Export Layout. 

5. In the Export File dialog, select Save, and 
save the file to a preferred device 
location, such as the Desktop. 

6. Open the document from the saved 
location in Word 2013. 

With the custom layout created, we 
will now edit it in Word. In this lab, 
we will use Import Layout and 
Export Layout instead of Edit 
Layout, as you would do when using 
the Microsoft Dynamics NAV Web 
client. 
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7. Select a table structure in the layout, such 
as the sales lines. 

8. In Word, on the Layout tab, in the Table 
group, choose View Gridlines. 

As Word report layouts often use 
hidden table structures to align 
content controls (such as field 
mappings), enabling gridlines in 
Word is quite useful to understand 
the structure. 
 
As can be seen, the sales invoice 
header fields are all arranged in 
tables for easier alignment in Word. 
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9. In Word, do one of the following: 
• Right click the ribbon, and then select 

Customize the Ribbon. 
• On the File menu, choose Options, and then 

select Customize Ribbon tab in the Word 
Options dialog box. 

10. In the right pane, select the Developer 
check box, and then choose OK. 

11. Select the Developer tab that is now 
visible in Word. 

To insert new fields from the report 
dataset in the Word layout, we 
need to take advantage of the 
custom XML mapping feature in 
Word. This feature is available in 
the Developer tab in Word, which is 
hidden by default, so the first task is 
to enable it. 

 
 
 

 
12. On the Developer tab, choose XML 

Mapping Pane. 
13. In the XML Mapping pane, in the Custom 

XML Part dropdown list, choose the 
custom XML part for the 1306 Sales 
Invoice. Typically, this is last in the list. The 
name of the custom XML part has the 
following format: 

Word layouts in Microsoft Dynamics 
NAV 2015 rely on mapping content 
controls to dataset fields. To 
facilitate this, Word’s custom XML 
feature is used. 
 
A Word document can contain one 
or more embedded XML parts with 
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urn:microsoft-dynamics-
nav/reports/Mini_Sales_Invoice/1306 

14. The XML Mapping pane now displays the 
labels and field controls that are available 
for the report. Browse the structure by 
expanding the tree and notice heading 
and different line structures. 

data. When Word layouts are 
exported or invoked for editing 
from Microsoft Dynamics NAV 2015, 
the layout will have a specific 
Microsoft Dynamics NAV XML ml 
part added, which represents the 
dataset structure of the report. This 
structure is then used when 
mapping the dataset to content 
controls. 
 
Therefore, first we need to show 
the XML Mapping pane in Word, 
and then select the proper 
embedded XML part that represents 
the report dataset. 
 
The name of the custom XML part 
has the following format: 
 
urn:microsoft-dynamics-
nav/reports/report_name/ID 
 
Where report_name is the 
normalized name that is assigned to 
the report as specified by the 
report's Name Property in the 
Microsoft Dynamics NAV 
Development Environment, and ID 
is the identification number of the 
report. 
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15. In the document header table, locate the 
empty cell in the last row and second last 
column. 

16. Insert the text marker by clicking in the 
cell. 

17. In the XML Mapping pane, expand the 
header structure and locate 
ShipmentDate_Lbl. 

18. Right click on ShipmentDate_Lbl, select 
Insert Content Control, and then choose 
Plain Text. 

19. Insert the text marker in the last cell in the 
row. 

20. In the XML Mapping pane, locate 
ShipmentDate. 

21. Right-click on ShipmentDate, select Insert 
Content Control, and then choose Plain 
Text. 

We are going to add a Shipment 
date field and a corresponding 
Shipment data label (for the 
localized field) name to the 
document header. 
 
We will add these to the empty cells 
at the bottom of the header, and to 
the right of the 
ShipmentMethodDescription field. 
 
When inserting the fields from the 
XML Mapping pane, Word inserts a 
content control at the text marker 
in the document, and links that 
content control to the xpath of the 
field in the custom XML part that 
represents the dataset. The content 
control also gets a visible 
name/caption which corresponds to 
the field name – however, this does 
not determine the mapping. The 
name can be changed, but the 
mapping remains the same.  
 
To remap a content control, either 
delete the content control and add 
a new one, or highlight the content 
control, find the correct field in the 
XML Mapping pane, right click it 
and then select Map to Selected 
Content Control, 
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22. Save the document in Word. 
23. Go back to the Custom Report Layouts 

page in Microsoft Dynamics NAV 2015 and 
make sure the new custom layout “My 
advanced Word layout” is selected. 

24. On the Home tab, in the Process group, 
choose Import layout 

25. In the Import Word Document dialog box, 
browse to the location where you 
exported the layout in the beginning of 
the lab, select the edited Word file, and 
choose OK to import the layout. 

Sean could have continued to add, 
delete, or move fields around, but 
for this lab, Sean is content, so he 
saves his work and imports the 
layout document back into the new 
custom Word layout in Microsoft 
Dynamics NAV. 
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26. In the Custom Report Layouts page, select 
the “My advanced Word layout” row, and 
then on the Home tab, in the Report 
group, select Run Report. 

27. In the resulting request page, use default 
values, select the Print button, and then 
choose PDF. 

28. Inspect the resulting report and validate 
that Shipment Date is included. 

Before setting the new custom 
layout as the active one, Sean runs 
it to validate it works as intended. 

 
29. Open Report Layout Selection page  
30. Browse to and select the report 1306 

Sales Invoice. 
31. Assuming that Selected Layout field is 

already set to Custom, change Custom 
Layout Description field to the new “My 
advanced Word layout” layout. 

32. Open Posted Sales Invoices by doing one 
of the following: 
• In the Search box, enter Posted Sales 

Finally, Sean switches over to use 
the newly created custom layout, 
which the ShipmentDate, as the 
active sales invoice Word layout. 
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Invoices, and then choose the related link. 
• In the navigation pane, choose Posted 

Documents, and then Posted Sales Invoices. 
33. Select a sales invoice from the list, and 

then on the Home tab, in the Invoice 
group, choose Print. 

34. In the print dialog, use default values, 
select Print, and then PDF. 

35. Validate that the resulting PDF is using the 
custom layout “My advanced Word 
layout” that you created previously. 
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Lab 5 — Creating a new Word Document Report Layout Based on an Existing Word Template 
Lab story: Microsoft Word supports the creation of great looking documents. Unless a visual identity has already been defined by a designer though, it is 
often much easier to start with an existing Word template, for example, from the community, than from scratch (although possible), and then tweak the 
templates visual design instead.  

In this lab, we will look at how a power user such as Sean can take an online Word template and add content controls that map to the Microsoft Dynamics 
NAV report dataset to create a custom sales invoice to fit the desired visual identity of his company relatively easy. 

 

What to do What to say Screenshots 

1. Browse for invoice templates in Word 
online, by doing one of the following: 
• Open Word 2013 and search for sales 

invoice. 
• In an existing Word 2013 session, on the File 

menu, select New, and then search for sales 
invoice. 

2. In the search result, look through the 
different suggested templates by selecting 
one and viewing the preview pane. Use 
left and right arrow buttons to shift 
through templates that have been found. 

3. Locate the Rust template, and select 
Create in the preview pane to create a 
document from the template. 

4. Save the document to a desired file 
location. 

First, Sean is selecting the template 
he would like to work on. 
 
As Microsoft Dynamics NAV Word 
layouts cannot be based on Word 
.dotx template files directly, Sean 
will have to create a document 
using the template. 
 
Sean opens Microsoft Word 2013 
and browses through available sales 
invoice templates using the preview 
capability. 
 
He ends up liking the Rust template 
the most, and selects Create to 
make a document based on this 
template. 
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5. Open Report Layout Selection page by 

doing one of the following: 
• In the Search box, enter Report Layout 

Selection, and then choose the related link. 
• In the navigation pane, choose 

Departments, Administration, IT 
Administration, and then Reports, 

• In the Small Business Role Center, on the 
Actions tab, choose Setup, Company 
Information, and then choose Report 
Layouts. 

6. Ensure that the correct company is 
specified in the Company Name field, 

With the Word template in a 
document, Sean creates a new Sales 
Invoice custom layout in Microsoft 
Dynamics NAV 2013. 
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because reports layouts are company 
specific. 

7. Locate the document report 1306 Sales – 
Invoice in the list by doing one of the 
following: 
• Scroll down through the list. 
• Filter on the Report ID equal to 1306. 

8. Select the row for report 1306, and on the 
Home tab, in the Process group, choose 
Custom Layouts. 

9. On the Home tab, in the New group, 
choose New to insert a new custom 
layout. The Insert Built-in Layout for a 
Report window appears. The ID and Name 
fields are automatically filled in. 

10. To add a custom Word report layout type, 
select the Insert Word Layout check box, 
and then choose OK. 

11. In the list, change the Custom Layout 
Description field of the newly created 
custom layout to “My Rust Word layout”. 

12. On the Home tab, in the Process group, 
select Import layout. 

13. In the Import Word Document dialog, 
browse to the location where you saved 
the Word document Word document that 
is based on the Rust template (in the 
beginning of the lab), select the 
document, and then choose OK to import 
the layout. 

As the newly created Word custom 
layout just contains a copy of the 
built-in Word layout, Sean imports 
his template document created in 
the beginning of the lab to 
overwrite the content. 
 

 

14. On the Home tab, in the Process group, 
choose Edit Layout. 

With the new custom layout 
containing the Rust template, Sean 
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opens the custom layout for editing 
to start inserting content controls 
that represent data from Microsoft 
Dynamics NAV. 
 
Note that the Edit function relies on 
client-side automation, and 
therefore requires that the 
Microsoft Dynamics NAV 2015 
Windows client and Word 2013 are 
installed. 
 
If you are us the Microsoft 
Dynamics NAV 2015 Web client or a 
device, the custom layout can be 
edited by exporting the layout to a 
Word file, editing it in Word, and 
then importing the layout file back 
into the appropriate report. 
 
Also note that when you edit or 
export the custom layout, the 
required custom XML part is 
automatically inserted. Instead of 
importing the Rust template first 
before editing or exporting it, Sean 
could also have exported only the 
custom XML part from the Export 
Word XML Part in the General 
group on the Actions tab. Then, he 
could have manually inserted XML 
part into the template in Word, 
done all the content controls, and 
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imported the custom layout into 
Microsoft Dynamics NAV. However, 
the lab steps described here are 
easier to understand. 

15. Select a table structure in the layout, for 
example, the sales lines. 

16. In Word, on the Layout tab, in the Table 
group, choose View Gridlines. 

As Word report layouts often use 
hidden table structures to align 
content controls (such as field 
mappings), enabling gridlines in 
Word is quite useful to understand 
the structure. 
 
As can be seen, the sales invoice 
header fields are all arranged in 
tables for easier alignment in Word. 

 

17. In Word, do one of the following: 
• Right click the ribbon, and then select 

Customize the Ribbon. 
• On the File menu, choose Options, and then 

select Customize Ribbon tab in the Word 
Options dialog box. 

18. In the right pane, select the Developer 
check box, and then choose OK. 

19. Select the Developer tab that is now 
visible in Word. 

To insert new fields from the report 
dataset in the Word layout, we 
need to take advantage of the 
custom XML mapping feature in 
Word. This feature is available in 
the Developer tab in Word, which is 
hidden by default, so the first task is 
to enable it. 
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20. On the Developer tab, choose XML 

Mapping Pane. 
21. In the XML Mapping pane, in the Custom 

XML Part dropdown list, choose the 
custom XML part for the 1306 Sales 
Invoice. Typically this is the last in the list. 
The name of the custom XML part has the 
following format: 
urn:microsoft-dynamics-
nav/reports/Mini_Sales_Invoice/1306 

22. The XML Mapping pane now displays the 
labels and field controls that are available 
for the report. Browse the structure by 
expanding the tree and notice heading 
and different line structures. 

Word layouts in Microsoft Dynamics 
NAV 2015 rely on mapping content 
controls to dataset fields. To 
facilitate this, the Words custom 
XML feature is used. 
 
A Word document can contain one 
or more embedded XML parts with 
data. When Word layouts are 
exported or invoked for editing 
from Microsoft Dynamics NAV 2015, 
the layout will have a specific 
Microsoft Dynamics NAV XML part 
added that represents the dataset 
structure of the report. This 
structure is then used when 
mapping the dataset to content 
controls. 
 
Therefore, first we need to show 
the XML Mapping pane in Word, 
and select the proper embedded 
XML part for the report dataset. 
 
The name of the custom XML part 
has the following format: 
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urn:microsoft-dynamics-
nav/reports/report_name/ID 
 
Where report_name is the 
normalized name that is assigned to 
the report as specified by the 
report's Name Property in the 
Microsoft Dynamics NAV 
Development Environment, and ID 
is the identification number of the 
report. 
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23. Locate and select the existing Date 
content control.  

24. Delete it and make sure the text cursor is 
still located to the right of the Date text. 

25. In the XML Mapping pane, expand the 
header structure and locate 
DocumentData. 

26. Right click on DocumentDate, select Insert 
Content Control, and then choose Plain 
Text. 

With the XML Mapping pane 
enabled, Sean can finally start 
adding content controls for the 
various placeholders in the Rust 
based custom layout. 
 
As Sean is not going to use the 
layout in any foreign locale, he is 
just going to use hardcoded text 
strings for captions, thus avoiding 
spending time on inserting content 
controls for labels. 
 
The Rust template already has some 
content controls. As we are not 
interested in these controls other 
than the placeholder, we are going 
to replace these with Microsoft 
Dynamics NAV content controls 
instead. 
 
First, Sean is adding the document 
date in the header. 
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Microsoft Dynamics NAV 2015 Developer 
 

74 
 

27. Create additional header content controls 
by repeatedly placing the text cursor in 
the Word layout and inserting a content 
control for the required field. To insert a 
control, find it in the XML Mapping pane, 
right-click it, select Insert Content Control, 
and then choose Plain Text. 

Sean repeats adding header 
information to the layout, such as 
invoice date and number, company 
address, customer address, ship to 
address, sales person, shipping 
method, and so on.  
 
As part of this, Sean tweaks the 
structure a bit, for example, by 
adding more address lines because 
Microsoft Dynamics NAV supports 
more than those included in the 
generic Rust template. 
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28. To complete the header, delete the logo 
place holder from the Rust template, and 
then merge the cell where it was 
contained with the one to the right. Then, 
place the cursor in the cell, and in the XML 
Mapping pane, right-click 
CompanyPicture, select Insert Content 
Control, and the choose Picture. 

29. Right-click the inserted picture content 
control, and then choose Size and 
Position. 

30. In the Layout dialog box, on the Size tab, 
specify the picture dimensions that 
correspond to the logo that is used. The 
Cronus demo data logo has a height of 3 
cm and width of 6 cm.  

Sean then inserts a logo 
placeholder. 
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31. Delete all lines except the first line 
between the lines header and the totals 
part. To do this, select the rows, right 
click, and then choose Delete Rows. 

32. Select the remaining row in the lines list. 
33. In the XML Mapping pane, go to the 

nested Line section at the bottom. 
34. Right click the Line entry, select Insert 

Content Control, and then choose 
Repeating. 

Lines and totals are just handled as 
a number of fixed, empty lines in 
the Rust template. 
 
As the number of lines are dynamic 
in normal sales invoices, Sean will 
remove all of the redundant lines 
and insert a repeater content 
control for the line structure 
requiring repeat capabilities.  
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35. In the cells of the repeating row, insert 
content controls for quantity, item no, and 
so on (These controls are nested content 
controls in the repeater content control). 
Find the required fields in the nested Line 
structure in the XML Mapping pane. 

With the repeater control in place, 
individual content controls for the 
column values in a line can be 
inserted. 
 
Again, Sean tweaks the Rust 
template a bit as needed. 
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36. In the total cells, insert content controls 
for total discount, tax, and so on. Find the 
required fields in the nested Totals 
structure in the XML Mapping pane. 

With the line structure in place, 
Sean inserts totals. 
 
There are two ways totals can be 
inserted: 

 Using individual content controls for 
each total field found in the Totals 
structure of the XML Mapping 
pane. 

 Using a dynamically formatted total 
repeater by using the 
ReportTotalsLine structure of the 
XML Mapping pane. 
The former has the advantage that 
individual total numbers can be 
formatted and placed as desired. 
The latter has the advantage that 
only lines with content (value), such 
as discount total, are shown. 
 
In this lab, Sean will insert explicit 
totals. For an example of using the 
total repeater, see the standard 
report 1306 Sales Invoice Word 
layout. 
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37. Replace the greeting content control with 
a content control that refers to 
CompanyAddress1 to get the company 
name in the greeting. 

Finally, Sean updates the greeting 
and saves the layout 

 
38. Save the changes and close the Word 

document. 
39. On the confirmation dialog box which 

appeared when the layout was opened for 
editing, choose Yes to accept the changes 
and import the layout into Microsoft 
Dynamics NAV. 

With the layout done, Sean saves 
the Word document and accepts 
importing the changes into 
Microsoft Dynamics NAV. 
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40. In the Custom Report Layouts page, select 
the new custom layout, and then on the 
Home tab, in the Report group choose 
Run Report. 

41. In the resulting request page, use default 
values, select the Print button, then 
choose PDF. 

42. Inspect the resultant PDF and validate that 
the Rust-based Word layout looks good 
and has correct field values. 

Before enabling the new custom 
layout as the active layout for the 
sales invoice report, we are going to 
test it out by running it from within 
the Custom Report Layout page. 
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43. Go back to the Custom Report Layouts 
page for report 1306 Sales Invoice. 

44. Select the new Rust-based custom layout 
“My Rust Word layout”. 

45. On the Home tab, in the Process group, 
choose Edit Layout.  

46. In Word, on the Design tab, use the left 
most Themes drop down list and apply a 
couple of different theme options to see 
the impact in the document. 

47. Apply the Berlin theme. 
48. On the Design tab, use the Colour drop 

down list to select a couple of different 
colour schemes to see the impact in the 
document. 

49. Apply the Office colour scheme. 

Sean likes the result, but he knows 
that many templates use styles and 
support Word themes and colour 
schemes, so he is going to explore 
these options to see if there are any 
colour and formatting combination 
he likes better. 
 
Applying different themes and 
colours, Sean likes the fonts and 
setup of the Berlin theme the most. 
However, to get a colour scheme 
that better matches his company 
“green” profile, he changes the 
colour scheme to Office. 
 

 
 



Microsoft Dynamics NAV 2015 Developer 
 

83 
 

 
50. Save and close the Word document. 
51. On the confirmation dialog box which 

appeared when the layout was opened for 
editing, choose Yes to accept the changes 
and import the layout into Microsoft 
Dynamics NAV. 

With the layout theme and colour 
scheme changes, Sean saves the 
Word document and accepts 
importing the changes into 
Microsoft Dynamics NAV. 
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52. In the Custom Report Layouts page select 
the new custom layout, and then on the 
Home tab, in the Report group select Run 
Report. 

53. In the resulting request page, use default 
values, select the Print button, and then 
choose PDF. 

54. Inspect the resulting PDF and validate that 
the Rust-based Word layout now has a 
new theme and colour scheme. 

As a final test, Sean reruns the 
layout, now with the new theme. 

 
55. Open Report Layout Selection page again. 
56. Browse to and select the report 1306 

Being satisfied with the new layout, 
we are going to make this the 
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Sales Invoice. 
57. Change Selected Layout field to Custom. 
58. In the Custom Report Layouts page that 

appears, select the layout “My Rust Word 
layout” that you previously created, and 
choose the OK button to close the page.  

59. Validate that the Selected Layout field 
now is set to Custom and that Custom 
Layout Description field in the list 
contains “My Rust Word layout” for the 
report 1306. 

default layout for the sales invoice. 
 
To do this, we will set the Selected 
Layout field in the Report Layout 
Selection page to the newly defined 
custom layout.  
Note that if the Selected Layout 
field is already set to Custom, the 
actual custom layout is changed by 
using the lookup in the Custom 
Layout Description field instead. 

60. Open Posted Sales Invoices by doing one 
of the following:  
• In the Search box, enter Posted Sales 

Invoices, and then choose the related link.  
• In the navigation pane, choose Posted 

Documents, and then Posted Sales Invoices. 
61. Select a sales invoice from the list, and 

then on the Home tab, in the Invoice 
group, choose Print. 

62. In the print dialog, use default values, 
select the Print button, and then choose 
PDF. 

63. Validate that the resulting PDF is using the 
custom layout “My Rust Word layout” that 
you previously created. 

Finally, Sean runs the sales invoice 
from a real application context, for 
example, Posted Sales Invoices, to 
verify that the new custom layout is 
used. 

 

 

 

2. Scheduling Reports 
Source: Demo Script – Scheduling Reports, Microsoft 
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Lab 1 — Setting up the job queue to run a report 
Lab story: Stan needs to run a number of long running reports and does not want to wait for them to complete. The scenario is simplified because a typical 
customer setup would involve setting up a NAS instance to process the reports.  

What to do What to say Screenshots 

25. Open the Job Queues 
page. 

26. On the Home tab, in the 
New group, choose New 
to set up a new job 
queue. 

 
 
 
 
 

Usually, a job queue 
would have been set 
up and started 
automatically on 
startup. 
 
For simplicity, in this 
example, we will 
start a job queue 
explicitly. 
 
Job queues enable 
you to specify, 
request, and control 
when certain 
processes are run, 
such as running  a 
report or executing a 
codeunit. 
 
The partner can 
modify the business 
logic to direct reports 
to a specific job 
queue. 
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27. In the Code field, type 
REPORTS. 

28. Fill in the Description 
field. 

29. Leave the Job Queue 
Category Filter field 
blank. 

30. On the Home tab, in the 
Process group, choose 
Start Job Queue. 

31. Close the Job Queue 
Card 

 

A job queue with no 
filter runs the 
reports. 
 
In many customer 
installations, the 
reports will be picked 
up by the DEFAULT 
job queue 
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Lab 2 — Adding the Report Inbox to the Role Center 
Lab story: The user wants easy access to the reports that he has scheduled, so he adds the Report Inbox part to the Role Center page. 

What to do What to say Screenshots 

1. To open the Role Center 
page that you want to 
customize, in the 
navigation pane, choose 
the Home button, then 
choose the Role Center 
menu item. 

2. On the Application menu 

, choose Customize, 
and then Customize This 
Page. 

3. In the Available Parts 
pane, select Report Inbox, 
and then choose the Add 
button. 

4. To move the Report Inbox 
part to top of the second 
column in the Role Center 
layout pane, select it and 
then use the Move 
buttons.  

 
 
 
 
 

By default, the Report 
Inbox is added to most 
Role Centers Role that are 
shipped on the DVD. If the 
Report Inbox is not 
present, it can be added by 
customizing the Role 
Center. 
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5. (Optional) To add the My 
Job Queue to the Role 
Center, in the Available 
Parts pane, select My Job 
Queue, and then choose 
the Add button.  

6. (Optional) To move the 
My Job Queue part below 
the Report Inbox in the 
Role Center layout pane, 
select it and then use the 
Move buttons.  

Optional: When the job 
queue is in use, it can be 
useful to have easy access 
to the state of the jobs 
that are currently running. 
 
The reason for having the 
two parts is that the job 
queue can be used for 
tasks other than running 
reports. 
 
Also note, that the job 
queue can be accessed 
directly from the Report 
Inbox by choosing the 
Show Queue action. So, if 
there is a need to preserve 
space on the Role Center, 
then you do not have to 
include the My Job Queue 
part. 
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7. Verify that the Report 
Inbox appears in the Role 
Center. 
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Lab 3 — Scheduling a report and viewing the result 
Lab story: The user wants to run a number of reports and view the contents later. He does not want to wait for the reports to finish running – he just wants 
to continue his work. The first report he needs is the Customer Order Summary report. In other scenarios cases, he may need to run reports that require a 
lot of memory. In this case, the reports can be run more efficiently on Microsoft Dynamics NAV Server. 

What to do What to say Screenshots 

1. On the Role Center, on the 
Report tab, choose 
Customer Order – 
Summary. 

2. On the report request 
window, choose the Print 
button, and then choose 
Schedule. 

 
 
 
 
 

For simplicity, a simple report 
on the Role Center paged is 
selected. 
 
A good use of this feature is 
to schedule “long running 
reports” like the Detail Trial 
Balance report. 
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3. In the Schedule a Report 
window that appears, in 
the Description field type 
a different text.  

4. In the Report Output Type 
field, select the down 
arrow, and choose PDF. 

5. Choose the OK button. 
 

The user can enter a 
descriptive name that makes 
it easier for him to remember 
his scheduled job. 
 
PDF is the default output 
format, but you can select 
other formats. 
 
The user has the option to run 
the report at a later time. This 
is particularly useful for long 
running reports that can be 
run after normal working 
hours. 
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6. Go to the Report Inbox on 
the Role Center and show 
that the report appears 
when it is finished 
running. 

7. To view the report, select 
it in the Report Inbox, and 
then choose Show.  

The Report Inbox part will 
update regularly. You can also 
force an update by pressing 
F5 in the Role Center. 
 
Unread reports are shown in 
bold 
 
You can show the generated 
report by double-clicking the 
item or selecting Show. 
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Lab 4 — When a scheduled report fails 
Lab story: Stan schedules a report to be run later, but an error occurred during execution. Stan investigates why the report did not generate an output and 
realizes that the parameters that were used to run the report are invalid. He changes the parameters, and then reruns the report.  

What to do What to say Screenshots 

1. Open the Role Center. 
2. On the Application menu 

, choose Customize, 
and then Customize This 
Page. 

3. In the Available Parts 
pane, select My Job 
Queue, and then choose 
the Add button. 

4. To move the My Job 
Queue part below the 
Report Inbox in the Role 
Center layout pane, select 
it and then use the Move 
buttons  

5. In the Role Center, go to 
the My Job Queue part. 

When the job queue is in 
use, it is useful to have easy 
access to the state of the 
jobs running. 
 
The reason for having the 
Report Inbox and My Job 
Queue parts is that the job 
queue can be used for tasks 
other than running reports. 
 
Note, that the job queue can 
be accessed directly from 
the Report Inbox by 
choosing the Show Queue 
action. So, if there is a need 
to save space on the Role 
Center real estate, you do 
not have to include the My 
Job Queue part. 
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6. On the Role Center, on the 
Reports tab, choose  Price 
List. 

7. In the Sales Type field 
select Customer. 

8. To schedule the report to 
run later, choose the Print 
button, then select 
Schedule. 

9. In the Schedule a Report 
window, leave the default 
values in fields and choose 
the OK button.  

 
 
 

Some reports will generate 
an error when they are run. 
 
In this example, you must 
either specify a customer 
number or select All 
Customers in the Sales Type 
field. 

 

10. When the error shows up 
in the My Job Queue part, 
select the error, and then 
choose Show Error. 

11. Read the error message, 
and then choose the OK 
button to close it. 

The My Job Queue part will 
update regularly. You can 
also force an update by 
pressing F5 in the Role 
Center. 
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12. Open the Job Queue Log 
Entries page. 

13. Filter the list to display 
entries whose Status is 
Error.  

14. To view the error 
message, point to the 
Error message field for the 
entry, or, select the entry, 
and then on the Home 
tab, choose Show Error 
Message. 

Optional: Going to this page 
is only needed if you want to 
know more about when the 
job was started or if you 
need to look at failed jobs 
for other users. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

   

15. Return to the Role Center, 
and then run the Price List 
report again. 

16. On the report request 
window, set the Sales 
Type field to All 
Customers, choose Print, 
and then choose 
Schedule. 

17. In the Schedule a Report 
window, leave the default 
values in fields and choose 

Use the error message 
information to rerun the 
report with different 
parameters. 

 



Microsoft Dynamics NAV 2015 Developer 
 

97 
 

the OK button. 
18. In the Report Inbox on the 

Role Center, view the 
completed report. 
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Module 12 – Queries 
 

1. Queries - SELECT DISTINCT 
Source: SELECT DISTINCT with Queries, Bogdana Botez - Microsoft Development Center Copenhagen, Microsoft Dynamics NAV Community, Design Patterns 
- https://community.dynamics.com/nav/w/designpatterns/152.select-distinct-with-queries 

SELECT DISTINCT with Queries 
 
When working with tables, sometimes a developer needs to 
perform a SELECT DISTINCT (also known as SELECT UNIQUE) from a 
table. As NAV does not provide this out of the box, we present 
below a way to select unique records by using queries. 
  
Problem statement 
Let's consider the VAT Entry table. 
 
The goal is to select one line for each separate document that 
produced VAT Entries. In other words, we want records grouped by 
Type, Document Type and Document No.. However, if there are 
multiple lines with the same value of the triad Type, Document 
Type and Document No. in the VAT Entry table, we only want to 
see one of them.  
 
 
 
 
 
 

 

https://community.dynamics.com/nav/w/designpatterns/152.select-distinct-with-queries
https://microsoft.sharepoint.com/teams/DynamicsNAV/Wiki/Nav%20Wiki%20Documents/NAV%20App%20Patterns/NAV%20App%20Patterns%20for%20Review/Table%20Select%20Distinct.docx#_msocom_1
https://microsoft.sharepoint.com/teams/DynamicsNAV/Wiki/Nav%20Wiki%20Documents/NAV%20App%20Patterns/NAV%20App%20Patterns%20for%20Review/Table%20Select%20Distinct.docx#_msocom_1
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Solution 
 
Create a new query object VAT Entry Distinct Document No., with a 
single DataItem sourced from VAT Entry table. Add the three 
desired group-by fields Type, Document Type and Document No. as 
columns. 
 

 
To enable grouping, add one more column, with Method Type = 
Totals. This will automatically set the Group By checkbox to TRUE 
on the three precedent fields. 
 
Note that the Group By field is read-only and trying to set it by hand 
will clarify that: 

 

https://community.dynamics.com/cfs-file.ashx/__key/communityserver-wikis-components-files/00-00-00-00-42/clip_5F00_image003.png
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Running the query yields a single record per document. You can 
notice in the second line below for example, how the sales invoice 
number 103001 had 2 VAT Entries, but it shows up only once in the 
query: 

 
 

  

https://community.dynamics.com/cfs-file.ashx/__key/communityserver-wikis-components-files/00-00-00-00-42/clip_5F00_image004.png
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2. Usage of Queries with temporary table – Page 
Source: Using Queries in Pages & Reports - Mark Brummel, NAV Skills | Brummel Dynamics Services B.V., http://nav-skills.com/2013/09/10/tip-35-using-
queries-in-pages-reports/ 

 
In order to be able to use Query as a source for Page object 
developer has to do following: 
 

• Create Query object, for example as displayed. 
• Create Table object with same fields as Query object. 
• Create Page object using the Table as source (SourceTable 

property).  
• Change Page property SourceTableTemporary to Yes. 
• Modify OnOpenPage trigger to execute the query and fill 

result of the query to temporary table. 
  

Create Table object with same fields as Query object and add field 
for primary key, for example Entry No. 
 
Temporary tables do not need to be in customer licence, therefore 
there is no need to buy an extra table into customer licence. 
 
 
 
 

 

http://nav-skills.com/2013/09/10/tip-35-using-queries-in-pages-reports/
http://nav-skills.com/2013/09/10/tip-35-using-queries-in-pages-reports/
http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/1234.QueryOnPage1.png
http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/0312.QueryOnPage6.png
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Create Page object using the Table as SourceTable and change Page 
property SourceTableTemporary to Yes. 
 

 
Create function to execute query and fill result of the query to 
temporary table. Modify OnOpePage trigger to execute new 
function. 
 

 

http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/7607.QueryOnPage7.png
http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/5621.QueryOnPage8.png
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Page with dataset from Query object. 

 
 

  

http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/4784.QueryOnPage9.png


Microsoft Dynamics NAV 2015 Developer 
 

104 
 

3. Usage of Queries with temporary table – Report 
Source: Report Temporary Property - Mark Brummel, NAV Skills | Brummel Dynamics Services B.V., http://nav-skills.com/2015/03/24/tip-45-nav2015-
report-temporary-property/ 

 

 
In order to be able to use Query as a source for Report object 
developer has to do following: 
 

• Create Query object, for example as displayed. 
• Create Table object with same fields as Query object. 
• Create Report object using the Table as source 

(DataItemTable property).  
• Change DataItem property Temporary to Yes. 
• Modify OnPreDataItem trigger to execute the query and 

fill result of the query to temporary table. 
 

 
Create Table object with same fields as Query object and add field 
for primary key, for example Entry No. 
 
Temporary tables do not need to be in customer licence, therefore 
there is no need to buy an extra table into customer licence. 
 
 
 
 

 

http://nav-skills.com/2015/03/24/tip-45-nav2015-report-temporary-property/
http://nav-skills.com/2015/03/24/tip-45-nav2015-report-temporary-property/
http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/1234.QueryOnPage1.png
http://dynamicsuser.net/cfs-file.ashx/__key/CommunityServer.Blogs.Components.WeblogFiles/mark_5F00_brummel/0312.QueryOnPage6.png


Microsoft Dynamics NAV 2015 Developer 
 

105 
 

Create Report object using the Table as DataItem (DataItemTable 
property) and change DataItem property Temporary to Yes. 
 

 
Create function to execute query and fill result of the query to 
temporary table. Modify OnPreDataItem trigger to execute new 
function. 
 

 

https://markbrummel.files.wordpress.com/2015/03/queryonreport.png
https://markbrummel.files.wordpress.com/2015/03/queryonreport2.png
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Report with dataset from Query object. 
 

 
 

  

https://markbrummel.files.wordpress.com/2015/03/queryonreport3.png
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Module 6 – Reporting 
1. Built-in Report Layouts 

 

Report object can use two types of layout: 
• RDLC 
• Word 

 
These built-in layouts are part of definition of the report object. If developer 
export the definition of report object to fob or txt file RDLC and Word layout 
are included. 
Report object can have: 

• 1 built-on RDLC layout 
• 1 built-on Word layout 

 
By default, the built-in RDLC layout will be used. 
 
Users can specify whether to use RDLC or Word built-in layout. Users can 
also create custom layout based on built-in layouts. 
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2. Change Default Layout 
Source: How to: Change Which Layout is Currently Used on a Report Microsoft Developer Network - https://msdn.microsoft.com/en-
us/library/dn789629(v=nav.80).aspx 

Depending on the layouts that are available for a report, you can choose to use a built-in RDLC report layout, a built-in Word report layout, or a custom layout. User can 
change the layout using page Report Layout Selection. 
 
To change the layout that is used on a report: 
 

1. In the Search box, enter Report Layout Selection, and then choose the related link.  
The Report Layout Selection window lists all the reports that are available for the company that is specified in the Company field at the top of the window.  
The Selected Layout field specifies the layout that is currently used on the report. 

2. Set the Company field at the top of the window to the company that includes the report. 
3. To change the layout that is used by a report, in the row for the report in the list, set the Selected Layout field to one of the following options:  

 
Option  Description  

RDLC (built-in)  Uses the built-in RDLC report layout on the report. 

Word (built-in)  Uses the built-in Word report layout on the report. 

Custom  

Uses a custom layout on the report. 

You can see which custom layouts are available for the report in the Report Layouts Part FactBox. If there are no custom layouts for the report, 
then you will have to create one first. 

If you choose this option, go to the next procedure to specify the custom layout that you want to use. 
 
 

 

  

https://msdn.microsoft.com/en-us/library/dn789629(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789629(v=nav.80).aspx
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3. Create a Custom Report Layout 
How to: Create a Custom Report Layout, Microsoft Developer Network - https://msdn.microsoft.com/en-us/library/dn757308(v=nav.80).aspx 

 
By default, a report will have a built-in report layout, which can be either an RDLC report layout or Word report layout, or both. You cannot modify built-in layouts. 
However, you can create your own custom layouts that enable you to change the appearance of report when it is viewed, printed or saved. You can create multiple custom 
report layouts for the same report, and then switch the layout that is used by a report as needed. 
 
To create a custom layout, you can either make a copy of an existing custom layout or add a new custom layout, which in most cases is based on a built-in layout. When you 
add a new custom layout, you can choose to add an RDLC report layout type, Word report layout type, or both. The new custom layout will automatically be based on the 
built-in layout for the report if one is available. If there is no built-in layout for the type, then a new blank layout is a created, which you will have to modify and design from 
scratch. 
 
To create a custom layout: 
 

1. In the Search box of the Microsoft Dynamics NAV Windows client or Microsoft Dynamics NAV Web client, enter Report Layout Selection, and then choose the 
related link. 
The Report Layout Selection window lists all the reports that are available in the company that is specified in the Company field at the top of the window.  

2. Set the Company field to the company in which you want to create the report layout. 
3. Select the row for the report that you want to create the layout for, and then on the Home tab, in the Process group, choose Custom Layouts. 

The Custom Report Layouts window appears and lists all the custom layouts that are available for the selected report.  
4. If you want to create a copy of an existing custom layout, select the existing custom layout in the list, and then on the Home tab, in the New group, choose Copy. 

The copy of the custom layout appears in the Custom Report Layouts window and has the words Copy of in the Description field. 
5. If you want to add a new custom layout that is based on a built-in layout, do the following: 

a. On the Home tab, in the New group, choose New. 
The Insert Built-in Layout for a Report window appears. The ID and Name fields are automatically filled in. 

b. To add a custom Word report layout type, then select the Insert Word Layout check box.  
c. To add a custom RDLC report layout type, then select the Insert RDLC Layout check box. 
d. Choose the OK button. 

The new custom layouts appear in the Custom Report Layouts window. If a new layout is based on a built-in layout, then it has the words Copy of a Built-in 
Layout in the Description field. If there was no built-in layout for the report, then the new layout has the words New Layout in the Description field, which 
indicates that custom layout is blank. 

6. By default, the Company Name field is blank, which means that the custom layout will be available for the report in all companies. To make the custom layout 

https://msdn.microsoft.com/en-us/library/dn757308(v=nav.80).aspx
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available in a specific company only, on the Home tab, in the Manage group, choose Edit, and then set the Company Name field to the company that you want. 
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Module 9 - Role Tailoring 
1. Enhanced Cues 

Source: Microsoft Dynamics NAV 2015 - Enhanced Cues - Jonathan Davis (Program Manager), August 2014, Microsoft 

 
Enhanced Cues are special cue tiles that apply custom formatting to 
any computed numerical value such as the number of open sales 
invoices and a custom tile icon (or no icon).  
 
Enhanced Cues can also show an indicator that changes colour 
based on the data values that the tile reflects. This provides a visual 
signal of the status of the data based on conditions for favourable 
and unfavourable thresholds. For example, the tile can show a red 
bar if the number of open sales invoices is less than 5.  
 
The initial thresholds for the visual clues are set by an administrator 
or super user, but the end user can modify them to better fit their 
workflow or situation. 
 
Features of enhanced cues: 
 

• Show any computed value that can be calculated in 
Microsoft Dynamics NAV (not just counts). 

• Support for integers and decimals.  
• Automatic font scaling to support large numbers. 
• Custom suffixes and prefixes (e.g. $12M or -67%). 
• Choose from a set of 20 new tile icons (or show no icon). 
• Automatically apply visual clues with colour indicators 

linked to tile values. 
• Tiles are configurable on a global, per-company or per-user 

basis. 
• End-users can configure their own sentiments in the 
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Microsoft Dynamics NAV Windows client or the Microsoft 
Dynamics NAV Web client. 

 
 
To setup the cue stack for you as an individual user, do the 
following: 
 

• Open the Role Centre, Activities part. 
• Select the Set Up Cues item, above the Cue Stacks. 
• Edit Cue Setup, modify values for Threshold 1 and 

Threshold 2 and decide what style to use, fields Low Range 
Style, Middle Range Style and High Range Style. 

 
To setup the cue stack for your company as an Administrator, go to 
Departments/Administration/Application Setup/General/Cue 
Setup or search for Cue Setup. 
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2. Formatting Cues 
Source: How to: Set Up Coloured Indicators on Cues by Using the Style and StyleExpr Property, Microsoft Developer Network - 
https://msdn.microsoft.com/en-us/library/dn789598(v=nav.80).aspx 

 

Set Up Coloured Indicators on Cues by Using the Style and StyleExpr Property 
 
You can configure a cue with a coloured indicator that appears along its top border to provide a visual indication to users about the value of data in the cue. You can 
configure the indicator to behave in the following ways. 

• The indicator has a static colour - in this case, the indicator appears with a specified colour at all times. 
• The indicator changes colour conditionally, based on the data in the cue - this is the most typical behaviour. When the data in the cue hits a specified value, the 

indicator changes colour. There are 4 colours to choose from, which enables you to configure different colours for different data intervals. 
 
You set up the indicator by using the StyleExpr Property and Style Property for the field that defines the cue and, in most cases, by adding C/AL code to the page object. 
 
The following table describes the values of the Style property and the corresponding indicator colour. You will need to know these values for whichever behaviour that 
you implement. 
 

Value  Colour  
Standard  None (uses the background colour of cue)  

Favourable  Green 
Unfavourable  Red 
Ambiguous  Yellow 
Subordinate  Grey 

 
 
 
 
 
 

https://msdn.microsoft.com/en-us/library/dn789598(v=nav.80).aspx
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Configuring Static Colour Indication on a Cue  
 
Use the following procedure to configure a coloured indicator on the cue that appears at all times. 
To configure a static colour on a cue: 

1. Open the page in Page Designer. 
2. Select the field that you want to format, and on the View menu, choose Properties. 
3. Set the Style property value to one of the formats that are described in the preceding table. 
4. Set the StyleExpr property value to True. 

 
Configuring Conditional Colour Indication on a Cue 
 
To configure the indicator to change colour conditionally based on the data in the cue field, you use a combination of C/AL code and the StyleExpr property and/or Style 
property. In the C/AL code of the page which contains the cue, you add code that evaluates the cue field's data and sets a variable based on the evaluation. A typical 
place to add the code is on OnAfterGetRecord trigger. The variable can have a data type of Boolean, Codeunit, or Text. You will use the variable on the StyleExpr 
property of the cue field to determine which colour to apply to the indicator. The data type that you use for the variable will depend on what you want to achieve, and it 
will also influence the configuration. The following table describes the differences when using a Boolean data type compared to a Text or Codeunit data type. 
 

Variable 
Data Type  Description  

Boolean If you use a Boolean variable, you can only configure one colour condition for the cue. When the StyleExpr property set to a variable that has a Boolean 
data type, and the variable is true, then indicator uses the colour that is specified by Style property value.  

Text or 
Codeunit 

If you use a Text or Codeunit variable, you can configure up to four different colour conditions for the indicator.  

When the StyleExpr property is set to a variable of the Text or Codeunit data type, the Style property is not used. Instead, the variable must be explicitly 
set in C/AL code to one of the following values that specify the colour: Favourable, Unfavourable, Ambiguous, and Subordinate. These values 
correspond to the values of the Style property. 
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To configure colour indication by using a Boolean variable 
 

1. Add C/AL code that evaluates the cue field data and sets a Boolean variable to True when the data meets the conditions for which you want to apply the 
indicator. 
For example, page 9060 SO Processor Activities in the CRONUS International Ltd. demonstration database contains the cue field "Sales Quotes - Open". You 
want the indicator to turn red when the number of open sales quotes exceeds 10. To do this, you can add a variable called ColorVar that has the data type 
Boolean, and then add the following code to the OnAfterGetRecord trigger. 

 
IF ("Sales Quotes - Open" > 10) THEN 
ColorVar := TRUE; 

 
2. Set the cue field's StyleExpr property to the variable. 

For the example in the step 1, you set the property to ColorVar. 
 

3. Set the Style property on the cue field to the value that corresponds to the colour indication that you want.  
For the example, you set the value Unfavourable to configure the colour to red. 

 
To configure colour indication by using a Text or Codeunit variable 
 
 

1. Add C/AL code that evaluates the cue field data and sets a Text or Codeunit variable to one of the following values for each condition that you want colour 
indication: Favourable, Unfavourable, Ambiguous, and Subordinate. For the corresponding colours for these values, see the table in the introduction of this 
topic  

 
For example, page 9060 SO Processor Activities in the CRONUS International Ltd. demonstration database contains the cue field "Sales Quotes - Open". You 
want the indicator to have the following colour conditions: 
 
• Green when the number of open sales quotes is 10 or less 
• Yellow when open sales quotes is greater than 10 
• Red when open sales quotes is greater than 20 
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To do this, you can add a variable called ColorVar that has the data type Text or Codeunit, and then add the following code to the OnAfterGetRecord trigger. 

 
IF ("Sales Quotes - Open" <= 10) THEN 
ColorVar := 'Favourable' 
ELSE IF("Sales Quotes - Open" > 20) THEN 
ColorVar := 'Unfavourable' 
ELSE ("Sales Quotes - Open") 
ColorVar := 'Ambiguous'; 

 
2. Set the cue field's StyleExpr property to the variable. 

For the example in the step 1, you set the property to ColorVar. 
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3. Set Up an Image on a Cue 
Source: How to: Set Up an Image on a Cue – Microsoft Developer Network, https://msdn.microsoft.com/en-us/library/dn789627(v=nav.80).aspx 

When a field that defines the data in a cue has an integer data type, you can set up the cue to include an image. 
 
To set up an image on the cue, you set the Image Property (Fields) of the field that defines the cue as described in the following procedure.  
 
To set up an image on a cue in the development environment, open the page that contains the cue as follows: 
 

• In Page Designer, select the field that defines the cue, and then on the View menu, choose Properties. 
• In the Properties window, set the Image property as follows: 

o Choose the AssistEdit button in the Value field. 
o In the Image List window, select the image that you want to use for the cue. 
o If you do not want to include an image on the cue, then select None. 
o To view all the available action images, see Microsoft Dynamics NAV Icon Collection - https://msdn.microsoft.com/en-

us/library/dd568728(v=nav.80).aspx 
• Close the Properties window, and then save the page. 

 
 

  

https://msdn.microsoft.com/en-us/library/dn789627(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dd568728(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dd568728(v=nav.80).aspx
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4. Lab - Using Query Object to Calculate the Cue Data 
Source: Walkthrough: Creating a Cue Based on a Normal Field and a Query – Microsoft Developer Network, https://msdn.microsoft.com/en-
us/library/dn789551(v=nav.80).aspx 

 
This lab illustrates the following tasks: 

• Creating a query object for calculating Cue data. 
• Adding a field for a new Cue in an existing table, and adding C/AL code to the field to get the data from the query object. 
• Adding a new Cue to an existing page for displaying the Cue in the Microsoft Dynamics NAV client. 
• Formatting the data in the Cue. 

 
Prerequisites: 

• To complete this lab, you need Cue table 123456740 Seminar Cue and page 123456741 Seminar Manager Activities from lab 9.1. Create the Seminar Manager 
Role Center. 

 
Story: 
 
Viktor is a software developer who is working for CRONUS International Ltd. He has been asked to add a Cue to the Role Centers that shows the total sales for the 
month. To accomplish this, Viktor will create a Cue that is based on a query object that extracts the total sales for the month from table 21 Cust. Ledger Entry. The 
company already has a table (123456740 Seminar Cue) and page (123456741 Seminar Manager Activities) on the Role Center. Viktor will add the new Cue to these 
objects. 
 
To create a query for calculating the Cue data do the following: 
 

1. In the Microsoft Dynamics NAV 2015 Development Environment, on the Tools menu, choose Object Designer, choose Query, and then choose New. 
2. In Query Designer, on the first line, set Type column to DataItem, and then set the Data Source column to Cust. Ledger Entry (table ID 21). 
3. Under the DataItem, add a Filter control for the Document Type field and a Filter control for Posting Date field of the Cust. Ledger Entry table. Then, add a 

Column control for Sales (LCY) field that uses a Totals method type to return a Sum from the table. The Query Designer will look similar to the following table. 
 
 
 
 

https://msdn.microsoft.com/en-us/library/dn789551(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789551(v=nav.80).aspx
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Type  Data Source  Name  Method Type  Method  

DataItem  Cust. Ledger Entry  <Cust. Ledger Entry>    

Filter Document Type <Document Type>   

Filter Posting Date <Posting Date >   

Column Sales (LYC) <Sum_Sales_LCY> Totals Sum 

 
4. Save the query as follows: 

a. In the Save As window, in the ID field, enter an ID for the query object, such as 123456750. The ID must be in a valid range for your solution. 
b. In the Name field, enter Cust. Ledg. Entry Sales Query. 
c. Select the Compiled check box, and then choose the OK button. 

 
 
 
 
 
Adding the Table Field for the Cue Data   
 
Viktor will add a normal field to the table 123456740 Seminar Cue for holding the Cue data. He will add a global function that returns the total amount of sales invoices 
for the current month from the query object that he created in the previous procedure.  
 
To add a field for the Cue data 

1. In the Microsoft Dynamics NAV 2015 Development Environment, open table 123456740 Seminar Cue from Object Designer. 
2. Add a new field for the Cue. In the Field Name, enter Sales This Month and set the Data type to Decimal. This defines the Cue data field. 
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To add C/AL code to the table calculate the Cue data 
 

1. On the View menu, choose C/AL code to open the C/AL code for the table. 
2. Add a global function that is called CalcSalesThisMonthAmount as follows: 

a. On the View menu, choose C/AL Globals. 
b. On the Functions tab, in the Name column, enter CalcSalesThisMonthAmount. By default, all functions are set to local functions as specified by the 

Local Property, so you must change the function to be global as described in the following steps. 
c. Select the new function, and then in the Tools menu, select Properties. 
d. Set the Local property to No. 

3. In the C/AL Globals window, select the new function, and then choose Locals. The C/AL Locals window appears. From her you will add a return value and 
variables. 

4. On the Return Value tab, set Name field to Amount and the Return Type field to Decimal.  
5. On the Variables tab, add two variables as shown in the following table: 

 

Name  DataType  Subtype  

CustLedgerEntry Record Cust. Ledger Entry 

CustLedgEntrySales Query Cust. Ledg. Entry Sales 

 
6. In C/AL code, add the following code on the CalcSalesThisMonthAmount function: 

 
CustLedgEntrySales.SETRANGE(Document_Type,CustLedgerEntry."Document Type"::Invoice); 
CustLedgEntrySales.SETRANGE(Posting_Date,CALCDATE('<-CM>',WORKDATE),WORKDATE); 
CustLedgEntrySales.OPEN; 
IF CustLedgEntrySales.READ THEN 
  Amount := CustLedgEntrySales.Sum_Sales_LCY; 
 

7. To save and compile the table. 
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Adding the Cue to the Role Center Page   
 
To display the Sales This Month Cue on the Role Center, Viktor adds a new field for the Cue to the existing page 123456741 Seminar Manager Activities. 
 
To add the Sales This Month Cue to a page: 
 

1. In Object Designer, open the page 123456741 Seminar Manager Activities. To add a Cue, you add Field control under a CueGroup control. For this lab, you will 
add the new Cue under the existing CueGroup control. 

2. In a blank row under the existing CueGroup control, set the Type to Field, and then set the SourceExpr column to the "Sales This Month" field as follows.  
a. Select the row, and then on the View menu, choose Field Menu. The Field Menu window opens and displays the list of available fields from the Seminar 

Cue table. 
b. Select the Sales This Month field, and then choose the OK button. In the Caption field, enter Sales This Month. The Caption value defines the text that 

appears below the Cue. 
3. Open the C/AL code for the page, and then add the following code to the OnAfterGetRecord trigger to assign the Sales This Month field to the 

CalcSalesThisMonthAmount function of table 123456740 Seminar Cue 
 
"Sales This Month" := CalcSalesThisMonthAmount; 
 

4. To set up a link (drill down) from the Cue to page 25 Customer Ledger Entries, do the following: 
a. Select the Sales This Month field row, and then on the View menu, choose Properties. 
b. In the Properties window, set the DrillDownPageID property to Customer Ledger Entries (ID 25) and choose the OK button. 
c. Close the Properties window. 

5. Save and compile the page. 
 
The Cue is now available on the page. To view the page, in Object Designer, select the page 123456741 Seminar Manager Activities, and the choose Run. 
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Formatting the Cue Data 
 
Viktor wants to display the amount in the Cue so that it is preceded with "GBP", which indicates British Pound is the currency. Additionally, he does not want to display 
any decimal places. To achieve this, he sets the AutoFormatType Property and AutoFormatExpr Property of the Cue field on the page. 
 
To change the data format: 

• In Page Designer, to open the properties for the Cue field, select the field, and then on the View menu, choose Properties. 
• In the Properties window, set the AutoFormatType property to 10. This enables you to create a custom data format. 
• Set the AutoFormatExpr property to the following text: 'GBP <precision,0:0><standard format,0>' 

o <precision,0:0> specifies not to display any decimals places.  
o <standard format,0> specifies to format the data according to standard format 0.  

• Close the Properties windows, and then save and compile the page. 
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Module 10 – Interfaces 
 

1. File Handling - 3tier Architecture 
Source: Microsoft Development Network 

 

In Microsoft Dynamics NAV, the business logic runs on the computer that is running Microsoft Dynamics NAV Server and not on the client. Files are created on Microsoft 
Dynamics NAV Server and not locally on the client computer. 
 
Use UPLOAD Function (File) and UPLOADINTOSTREAM Function (File) to send a file from the client to Microsoft Dynamics NAV Server. 
Use DOWNLOAD Function (File) and DOWNLOADFROMSTREAM Function (File) to send a file from Microsoft Dynamics NAV Server to the client. 
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Module 14 - Developing for the Microsoft Dynamics NAV Tablet Client 
 

1. Tablet Client 
Source: Microsoft Dynamics NAV 2015 for tablets – Business Value – Mike Borg Cardona (Program Manager), September 2014, Microsoft 

Dynamics NAV for tablets (also referred as tablet client) allows 
users in small and midsized businesses to get access to the data 
they need from the device they prefer. 
 
While the Microsoft Dynamics NAV Windows Client and Dynamics 
NAV Web Client are designed for mouse and keyboard interaction, 
Dynamics NAV for tablets has a modern, fast and fluid interface 
built exclusively for touch. 
 
NAV Tablet client is available on 3 platforms – Microsoft Windows 
tablets, Apple iOS (iPads) and Android. 
 
User can also run tablet client from web browser (Internet 
Explorer and Chrome for Windows). 
 
Tablet client can be used only on tablets with 7’’ screen size or 
larger. Screen resolution has to be at least 960 x 510. 
 
Microsoft Dynamics NAV for tablets does not provide the following 
capabilities: 
 

• Offline reading and writing of data 
• The ability to directly control device hardware such as GPS 
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Navigation pane 
 
In order to access Navigation Pane user has to click three lines icon 
above cues. 
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Role Centre Action Ribbon 
 
In order to access Role Centre Action Ribbon user has to click 
three dots icon above cues. 
 

 
Online Help 
 
User can access Online Help by going into Role Centre Action 
Ribbon and choosing Microsoft Dynamics NAV Help. 
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Sorting of List Page 
 
In order to sort records in list page use can simply click on column 
header name for column which should be used to sort. 

 
Filtering of List Page 
 
User can filter records by using filter field. 
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New Record 

 
Edit/View/Delete Record 
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Page Action Ribbon 
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2. Dynamics NAV for tablets Labs 
Source: Microsoft Dynamics NAV 2015 for tablets – Business Value – Mike Borg Cardona (Program Manager), September 2014, Microsoft 

 

Lab data preparation 
1. In the Microsoft Dynamics NAV Windows client, locate the Profiles list page. 
2. Select and open the card page for the profile “SMALL BUSINESS - TABLET”. 
3. Select the Default Role Centre checkbox. 
4. Choose the OK button. 
5. Sign into the Microsoft Dynamics NAV Tablet client and, on the Role Centre, tap Key Performance Indicators. 
6. In the menu, select the Select Chart item. This will show a list of available charts. 
7. Select the Top Ten Customers by Sales Value chart. 
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Lab 1 — A salesperson prepares to engage with a customer 
Lab story: In this short demo, we focus on how a salesperson can prepare for engaging with a customer, by quickly 
looking up information, and by setting sales goals directly in the Role Centre. This demo also serves as an initial 
explanation of the Role Centre. 

What to do What to say Screenshots 

1. On the Start screen, tap the 
Dynamics NAV tile to launch 
Microsoft Dynamics NAV. 

 

Here on my Start screen I have all 
my favourite apps, including 
Dynamics NAV. If I tap that tile, the 
app takes me to my Role Centre. 

 
  

2. Pause for a moment to 
observe the Role Centre. 

 

This is where I can get an overview 
of my work at a glance. 
 
On the left we have the cues which 
show me where I need to take 
action. For example, I can see the 
Overdue Sales Invoice amount is 
particularly high today. 
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3. In the content pane, tap Key 
Performance Indicators. 

4. In the menu, tap on Previous 
Chart, pause, then tap on 
Next Chart to return to Top 
10 Customers By Sales Value. 

On the right, I have my chart. I can 
easily switch between various 
charts to get an overview of my 
data. 
 

 
 

5. Gently scroll down the 
content area until Favorited 
Customers is in view. 

I can have various forms of BI 
displayed directly on my Role 
Centre, such as my personal list of 
Favorited Customers. 

 

6. Tap on the tile named Sales 
This Month. 

7. Pause on the list of sales, and 
tap the back arrow. 

8. Tap to show the Action Pane 
and select Set Up Cues. 

9. In the row with Cue Name set 
to Sales This Month, tap the 
cell in column Middle Range 
Style and set it to 
Unfavourable. 

If I take a look at Sales This Month, I 
can see that I am close to the 
100,000 mark. 
 
I can tap to drill down and see 
specifically which sales are 
included. 
 
As a salesperson, I want to make it 
my personal goal to reach that 
target. Maybe the customer I am 
meeting today is interested in 
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10. Tap the Close button. purchasing some of our more 
expensive products which will help 
me reach that goal. 
I can personalize my cues to use 
colours to indicate if I have reached 
my goal or not. Here the upper 
threshold is already set to 100,000 
so I just need to set which colour 
will be shown below that value. 

 

11. Bring up the Navigation Pane 
and tap on Items 

12. Gently scroll through the 
long list of items 

13. In the Items list, tap in the 
Search field, enter the text 
“wheel” and tap the spy glass 
to begin searching. 

Let’s find the price for our more 
expensive items. 
 
As you can see, this is quite a long 
list but I’m looking for something 
specific. 
 
This customer has always 
purchased a stock of wheels so let 
us first search for that. Note, how I 
did not need to specify which 
columns to search on, and items 
were found regardless of where the 
term “wheel” was used. 

 

14. Tap in the Search field again, I can refine my search further, and  
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and change the text to “front 
wheel” and tap Enter on the 
on-screen keyboard. 

15. Tap on the column header 
Description to sort 
alphabetically. 

also sort my list. 
 
Now I can see that Front Wheels 
can be sold at 1,000 for a good 
profit. 

16. Bring up the Action Pane and 
tap on the Open in Excel 
action. 

I can also send this list to Microsoft 
Excel if I want to perform some 
quick calculations on pricing 
directly on my tablet. 

 
 

17. Switch back to Dynamics 
NAV and tap the back button 
to return to the Role Centre. 

As always, the Role Centre is only a 
tap away. 
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Lab 2 — A salesperson updates customer information 
Lab story: In this short demo, we focus on how a salesperson could easily update the details for a specific customer, 
such as the phone number. Dynamics NAV is not just for reading data, but also for writing just like in any other 
Dynamics NAV client. 

 

What to do What to say Screenshots 

32. In Dynamics NAV, from the 
Role Centre, bring up the 
Navigation Pane and tap on 
Customers. 

33. Tap on the row with Name set 
to Selangorian Ltd. 

34. Tap the Edit button in the top 
right to enter Edit mode. 

35. In the Phone Number field, 
enter a valid phone number.  

After talking with my 
favourite customer, 
Selangorian Ltd., I learn 
that they often use 
phone calls or Skype for 
communication. Let’s 
add their phone 
number to the 
customer card. 

 
  

36. Tap on the AssistEdit button 
for the City field. 

37. Gently scroll through the list 
of cities in the lookup. 

38. Tap on Luton. 

The customer address is 
also incorrect. Let’s 
quickly update the city. 
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39. Tap the back button to return 
to the list of customers. 
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Lab 3 — A salesperson creates a Sales Quote for a customer 
Lab story:  In this short demo, we focus on creating a Sales Quote and instantly mailing this to the customer. Creating sales or purchase documents is a common task while o        
continuation from Demo 2 where we will now send the quote to customer Selangorian Ltd. 

 

What to do What to say Screenshots 

1. In the Customers list page, 
bring up the menu for 
customer Selangorian Ltd. 

2. Tap on Sales Quote. 
3. Under the Lines section, in 

the first empty row, tap the 
AssistEdit button for Item. 
No. 

4. In the lookup pane, tap in the 
Search field, enter “front 
wheel” and then tap Enter on 
the keyboard. 

5. Tap on the Quantity field and 
enter value 12. 

6. Tap in the Line Discount % 
field and set the value to 14. 

 

Let’s quickly create a 
sales quote for this 
customer. Note, how 
the customer 
information has been 
prefilled in the quote. 
 
With a few taps, I can 
prepare the quote. 
Since this is one of my 
favourite customers, I 
will raise the discount 
to 14%. See how the 
total changes 
accordingly. 
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7. Bring up the Action pane and, 
in the Process action group, 
tap the Email action. 

8. In the task dialog, enter the 
following message: “Thank 
you for today’s meeting – 
here is the quote we talked 
about. I am looking forward 
to hearing from you.” 

9. Tap the OK button to proceed 
with sending the mail. 

 

Now let’s send the 
quote to the customer 
with a few more taps. 
 
The email is sent with 
the sales quote 
attached as a PDF 
document. 
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3. Differences and Limitations When Developing Pages for the Microsoft Dynamics NAV Tablet Client 
Source: Differences and Limitations When Developing Pages for the Microsoft Dynamics NAV Tablet Client, Microsoft Development Network - 
https://msdn.microsoft.com/en-us/library/dn757104(v=nav.80).aspx and https://msdn.microsoft.com/en-us/library/dn789506(v=nav.80).aspx 

 

Developing for Microsoft Dynamics NAV Tablet client is not much different from developing for Microsoft Dynamics NAV Windows client, or Microsoft Dynamics NAV Web 
client. There are, however, some natural limitations on a tablet, such as not having a physical keyboard and mouse, as well as a smaller screen. In addition to this, there are 
some differences and limitations in developing pages for Microsoft Dynamics NAV Tablet client. 
 
Page Differences and Limitations 
 
In the following section, you will find a description of what to expect when displaying pages on Microsoft Dynamics NAV Tablet client. 
 

Concept  Difference/Limitation  Example  Recommendation  

Activity Buttons 
Only the content of the Home 
activity button is shown. You cannot 
activate other activity buttons. 

Home, Departments, and Posted Documents 
on the Sales Order Processor Role Center. 

Design pages to expose the workflows needed by the user. 
For example, configure the profile to show the important 
list pages under the Home activity button. Alternatively, 
consider designing a new Role Center if the activities for 
the activity button greatly vary from activities in other 
activity buttons. 

Selecting multiple records 
in Lists Not available. Ctrl+A or Ctrl+Click on rows in a list using 

Microsoft Dynamics NAV Windows client. 
Avoid scenarios requiring selecting multiple rows on a list. 
Also, try to minimize actions on lists. 

Ribbon Actions Only Promoted actions are shown. On the Small Business Role Center. 
Use the development environment to promote actions. 
Alternatively, configure the profile and add actions to the 
Home ribbon tab. 

FactBoxes Not shown on List pages or 
Worksheet pages. 

Customer list on the Small Business Role 
Center. 

Make sure the same information is visible on the 
corresponding card page of the given record. 

Advanced Filters No column-specific filtering is On the Customer list page. Send data to Excel and do the complex filtering there. 

https://msdn.microsoft.com/en-us/library/dn757104(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789506(v=nav.80).aspx
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available. 

Page Search Not available. On Microsoft Dynamics NAV Windows client or 
Microsoft Dynamics NAV Web client. 

Design pages to expose the workflows needed by the user. 
For example via list places, tiles or actions. 

Horizontal Scrolling on 
Lists 

The number of tiles that are shown 
is based on the size of the screen, 
no possibility to scroll. 

On Items list for the Sales Order Processor 
profile.  

Cue and Action Tiles 
The number of tiles that are shown 
is based on the size of the screen, 
no possibility to scroll. 

On most Role Center pages. 

Design List pages to avoid having important columns on 
the far right of the column list. Assume you have no control 
over how many columns are displayed and consider that 
only the first few columns will be made visible. 

Field Groups 

Field groups on list pages are not 
shown. Only the repeater control is 
shown in the content area of the 
page. 

On Opportunity list page (5123). 

Design Role Center pages to avoid having important tiles at 
the area end. Assume you have no control over how many 
tiles are displayed and consider that only the first few tiles 
will be made visible.  

Links and Notes Not available. On Sales Orders. 
Similar to Factboxes, make sure the same information in 
the field group is visible on the corresponding card page of 
the given record. 

Select from full list 

Not available on lookups. Users are 
not able to run actions on a lookup 
page, and they cannot access the 
full set of records. 

On the Item Card when selecting the Base 
Units of Measure. 

Make sure the appropriate columns are visible on the 
lookup. The user is still able to filter, scroll, and search 
through the lookup. 

Date picker in grids Not available. On Sales Invoices. Enter dates in grids manually. 

Search across List columns Partly supported. Search will not 
include FlowFields.  Customer list. 

 

GETURL It is not possible to generate URLs 
to the Microsoft Dynamics NAV 

See example in codeunit 440. 
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Tablet client using the GETURL AL 
function. 

Report Viewer and 
CurrReport.PREVIEW 

There is no Preview functionality 
available on the Microsoft Dynamics 
NAV Tablet client. 
CurrReport.PREVIEW cannot be 
reliably used to identify whether a 
report was run as a draft or as a 
final printed document.  

See example in report 280. 
 

Matrix Controls Not supported.  See example in G/L Budget. 
 

File download Cannot download multiple files at 
the same time. 

Trial Balance report in the Print to Excel check 
box.  

Number of columns 
displayed in a repeater 
control. 

Because of the form factor on 
tablets, you might experience that 
not all important columns are 
displayed. 

 

Use the Width field property to control the size of the 
column and thereby make room for more columns 
displayed. 
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Role Center Behaviours 
 
Concept  Description  

Tiles The app bar will automatically show tiles in two or three columns depending on the total number of tiles. A Role Center with many tiles only displays the tiles that fit 
vertically on the screen; other tiles are not shown and will not be available. 

Actions Actions that are added under an ActionContainer of the subtype HomeItems are always shown in the navigation pane. 

Actions 

Actions that are added under an ActionContainer of the subtype ActivityButtons are never shown, and cannot be accessed. 

There is no ability to navigate to other Activity Buttons as you can do in Microsoft Dynamics NAV Windows client and Microsoft Dynamics NAV Web client. Because 
Activity Buttons link to related functionality, the recommended workaround is to providing links to this functionality through their own Role Center as a separate 
entry point. 

Actions 

• In the action pane, if the current profile has no configuration for the specific page, for example, if this was deleted, only promoted actions will be shown. If 
there are no promoted actions, any actions under NewDocumentItems will be shown. If there are no NewDocumentItems actions, an empty pane will be 
shown. 

• If a page configuration exists, the NewDocumentItems will be shown, together with any new groups that were created. Actions, even if they were renamed, 
which remain in their original group will not show until you move them to a custom group. This behaviour differs from Microsoft Dynamics NAV Windows 
client which will always show them. 

• When you add actions to the Home tab, it corresponds to setting the actions to Promoted. However, you can only do this with the configuration tooling if 
there is at least one Promoted action. Otherwise, the Home tab will never be available for customization. 
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4. Designing for Different Screen Sizes on a Tablet 
Source: Designing for Different Screen Sizes on a Tablet, Microsoft Developer Network - https://msdn.microsoft.com/en-
us/library/dn789596(v=nav.80).aspx 

 

Form Factor Considerations 
Users can scroll the content area of Microsoft Dynamics NAV for tablets to access all data for a given page. However, some elements of the screen, for example, the app bar 
cannot be scrolled. The app bar is the blue area of Microsoft Dynamics NAV for tablets and it is designed to provide easy access to important information and tasks that the 
user should not lose sight of when scrolling. The static elements will display only as much data as they can reasonably fit on the screen. Developers should design to make sure 
that the important static elements are displayed first, so that that these will be shown even on the smallest, available devices. 
 
Guidance for Page Element Types on Smallest Devices 
The following table provides a list of non-scrollable elements in the page content or the app bar. 
 

Page Type  Displays on smallest device  

RoleCenter 4 tiles in 1 group, or 2 groups together with 2 tiles 

List Pages 5 columns of type Text50 or 8 columns of type Text20 

Card Pages 

• CardPage Factbox with up to 15 fields 

• 2 CardPage Factboxes with up to 6 fields each 

• Activities Factboxes with 4 tiles in 1 group, or 2 groups together with 2 tiles 

Document Pages 

• CardPage Factbox with up to 15 fields 

• 2 CardPage Factboxes with up to 6 fields each 

• Activities Factboxes with 4 tiles in 1 group, or 2 groups together with 2 tiles 

 

 

https://msdn.microsoft.com/en-us/library/dn789596(v=nav.80).aspx
https://msdn.microsoft.com/en-us/library/dn789596(v=nav.80).aspx
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